Jump to content

Won’t start

Recommended Posts

I have a 2012 Kx 450f, went for a ride , bike was perfect, put in garage can back 2 weeks later, now it won’t start? I put 12 volts directly to fuel pump, it runs, when I kick start it the light on handlebar just lights up solid? Looking for some help? 

Share this post


Link to post
Share on other sites

You’re going to need a manual. Start diagnosing different parts. It could be the stator, flywheel, condenser, fuel pump.... There is no way for us to tell you what is wrong. If I had to take a stab at it, I’d say you have a bad fuel pump.

Share this post


Link to post
Share on other sites

Took to Kawi shop, hooked to laptop, went through ecu, found 1 code intake air temp sensor, replaced it, still nothing, replaced fuel pump, it cycles with power applied to it, but does not run when I kick it over, ran test on the other sensors and such, all showing good, gear sensor, tip over sensor, so I’m looking at the capacitor or possible voltage regulator.

Also I have a full shop manual.

Share this post


Link to post
Share on other sites

When you said “I put 12 volts directly to the fuel pump, it runs”, does that mean the pump runs or the bike runs. There is a connector behind the left shroud that comes out of the capacitor where you plug in 12 volts. Is that where you are hooking up the power, or is it directly to the pump?

Share this post


Link to post
Share on other sites

Yes but But the bike doesn’t run the fuel pump runs manually on 12 votes but the bike does not start undoubtably I’m not getting any signal to open a pulse the injector

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×