'06 Eiger 400 no spark

I'm so frustrated with this thing.  It's an '06 Eiger 400 auto that had a small fire from grass accumulating by the exhaust which burnt the harness.  I put a new main harness and all sub harnessess, key switch and handlebar switch cluster.  Still no fire.  Checked voltage coming from pulse generator and source and it's in spec.  Battery is fully charged.  Ignition coil resistance is in spec.  As soon as the key switch is turned on I see the CDI sending voltage (maxing at about 1.9v) to the primary on the ignition coil without tumbing the starter.  I thought the CDI was the problem so I got a used from Ebay and it does the same exact thing.  If I unplug the leads from the coil and then turn on the ignition it starts climbing in voltage (topping out at like 180v) without spinning the starter over.  Wtf...

What's the possiblility of both the CDI's being faulty in the same exact way?

HEEEEEEELLLLLLLPPPPPP!!!

Edited by Dussucker3000

I can see this area of the forum is a hot bed of information!

Problem solved.  The magnets came off the flywheel.

On 1/19/2018 at 3:13 PM, Dussucker3000 said:

I can see this area of the forum is a hot bed of information!

Problem solved.  The magnets came off the flywheel.

I know this is old and you figured it out, I had the magnets fall off mine also and turns out there's a recall if your the original owner, I don't believe there was a time limit either. Why it matters who owns it I'll never know!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now