• Announcements

morty256

Rmz 450 clicking sound

7 posts in this topic

Need help, 2016 rmz 450 clicking sound when under load and motor is hot. Doesn’t click when motor is just warm, and only clicks when motor is under load “accelerating” does not click at idle or rev. Sounds like aluminum hitting aluminum, bike runs great very vague sound have to listen to hear it. Fresh oil always and 33 hours on bike. Running ecstar oil. Bikes is always kept cool I run engine ice and have higher boiling temp radiator cap.

Share this post


Link to post
Share on other sites
On 2/14/2018 at 5:36 AM, Rotaholic said:

Exhaust header air leak?

That is what it sounds like to me. I had a buddy bring me an RMZ with about 25 hrs on it. At first I thought it was the cam chain but it was perfectly fine. I replaced the metal gasket between the header and exhaust port and it stopped the noise. The original was burnt up. I can post a pic if you don't know what you are looking for. 

Share this post


Link to post
Share on other sites



That is what it sounds like to me. I had a buddy bring me an RMZ with about 25 hrs on it. At first I thought it was the cam chain but it was perfectly fine. I replaced the metal gasket between the header and exhaust port and it stopped the noise. The original was burnt up. I can post a pic if you don't know what you are looking for. 

I ran some lead vp race fuel this weekend and it didn’t make a sound but makes sense for sure

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with: