Daemian Teemu Stenroos

Dr350 1991 Wont start even with starting spray

5 posts in this topic

Posted (edited)

Hey,

New to here but just bought a cheap DR350 -91 and it did start but now is refusing to fire up or even cough.

-around 100psi compression (only a cheap compression meter with rubber end so not super accurate).

-spark looks good when out of the hole and grounded to frame.

-put fuel down the spark plug hole (tried 0.5 and 1ml), plug back in and kicked, nothing.

-tried starting spray and nothing.

bought new coil and it started two days in a row, then went one day without and now its dead again.

sorry, not native to english, dont know the technical terms, Yet.

its kickstart only.

Edited by Daemian Teemu Stenroos

Share this post


Link to post
Share on other sites
Hey,
New to here but just bought a cheap DR350 -91 and it did start but now is refusing to fire up or even cough.
-around 100psi compression (only a cheap compression meter with rubber end so not super accurate).
-spark looks good when out of the hole and grounded to frame.
-put fuel down the spark plug hole (tried 0.5 and 1ml), plug back in and kicked, nothing.
-tried starting spray and nothing.
bought new spool and it started two days in a row, then went one day without and now its dead again.
sorry, not native to english, dont know the technical terms, Yet.
its kickstart only.
You installed a new spark plug and then it started?
Check that-
fuel getting to carb? -no could be dirty petcock or even petcock not turned to on.
Is fuel in carb bowl? - should be a drain screw on bottom of bowl. If not carb is dirty and needs to be cleaned.
Are air box rubber boots in good condition no holes or cracks.( they connect carb to engine and air box to carb)
Is air filter clean.

Share this post


Link to post
Share on other sites

I did install new spark and it did fire up two days in a row.

Fuel gets to carb, when turning drain screw fuel comes out. I cleaned the carb but now its not even spinning.

Rubber boots have been checked but cant find any holes or damage. Air filter looks good and is oiled.

 

But now it doesnt give a single explosion with fuel in the cylinder or starting spray. But does spark up when outside the spark hole, could it be the spark boot?

Found some otherguy having a problem that the wire/boot when bent, didnt work, gave a spark outside but not inside. Ill buy a new boot tomorrow and see. The wire should be fine 'cause it came with the new coil.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with: