Jump to content
Sign in to follow this  

yz85 bogging at 1/4 throttle

Recommended Posts

Hello everyone,

I have a 2003 yz85 that seems to have issues at around 1/4 throttle under load. It makes starting from a hill damn near impossible, although starting from flat ground is no problem. Spark plug is fairly new and the color looks good on it. I just rebuilt the carb completely with all new stock jets, needle clip was on the first clip (full lean) so i left it at that. It has a airbox mod, Twin air filter, and Pro circuit silencer so its possibly too rich and needs a larger diameter needle? It idles and runs well, rips really well in the powerband, just seems like it struggles to do hill climbs if it falls out of the powerband while doing so. Also on a unrelated note the clutch arm seems to not want to return fully under its own spring tension unless the clutch is fully pulled in and then released. I think it may just need the spring replaced on the clutch actuator arm but i am not sure. I am also unsure how to remove the clutch arm in the first place. Any help with these issues would be greatly appreciated. Running 93 octane at 40:1, trail riding only no track use. Not sure when the last top end was done on it, it was probably awhile ago but compression still seems good. 

 

Edit: forgot to note I am running +1 tooth on the rear sprocket, although now I think I should have added 3 or 4 teeth to it and this wouldnt be an issue. 

Edited by ryan884

Share this post


Link to post
Share on other sites

Try running the needle in the stock position. All other Jets are new stock Jets, just finish it off with the needle in the stock position. Could be all set or at least know what difference it made.

Share this post


Link to post
Share on other sites

A bog is almost always a lean condition.   The stock jetting and needle position provide for the most aggressive power delivery from the yz85.  

The stock needle should be a NBKF and the postion should be 2nd groove from the top.  (per the manual section 2 page 5)

If you still have issues (bog) after moving the clip back to the stock position, try going to the third position.   

Goto this thread for more info on the yz85  Posts around Oct 26 2017 discuss jetting to tame the mid range hit. 

Let us know how you made out. 

 

Edited by R and D Marine

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...