Jump to content

Recommended Posts

Hey guys I need some help with my 1982 XL250R it currently has no spark

also having some issues with indicators and the headlight

when I turn on the headlight the indicators stop working all together and can’t be turned back on 

the headlight when it’s on does not work well 

if somone knew a lot about these it be great for some help

cheers

Share this post


Link to post
Share on other sites

Headlight should not be on without the engine running, and blinkers often dont blink properly only running from the battery without the engine going.

  Spark issues seem easier to find by starting at the plug and working backwards, IE Plug,cap,lead,etc.

Check grounding and connectors etc too.

Share this post


Link to post
Share on other sites

I'd suggest a wire is shorting, possible rubbing against the frame. 

Disconnect the battery, check for spark, if no spark check your spark plug connector and line. Bike should run and start without battery. Agree with Muzz67 above. I recent,y had electrical issues with my bike, it was a faulty connection and I just needed to push a connector in firmly. With the tank and seat off do a visual inspection of connections before getting into the headlight. Look for anything rubbing against the frame.

Share this post


Link to post
Share on other sites

Hey guys thanks for that

ive discovered that there is power going through the ground/earth wires when I kick it over 

so when I kick it over the test light lights up on the ground wires power is being sent through those wires

hope this can help figure out why

its getting power right to the cdi coil I’ve changed to a new coil still getting power there just not getting to the lead I’ve changed leads

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×