Jump to content

Replaced transmission, cant shift into 3rd?

Recommended Posts

I replaced the transmission on an '05 kx85, and ive put the cases back together and everything spins freely, it shifts through all the gears, but once you put that tensioner thing that presses on the shift drum (dont know what the part's called) you cant shift into 3rd, itll get stuck halfway between second and 3rd, but once you take off that tensioner thing you can spin the drum and shift through all the gears just fine, whats going on?

Share this post


Link to post
Share on other sites

Are you turning the drive shaft while you shift? Things just might not be lined up correctly sitting still

Share this post


Link to post
Share on other sites
18 minutes ago, Boshwa said:

Are you turning the drive shaft while you shift? Things just might not be lined up correctly sitting still

That could help.  Hold the output shaft stationary and turn the input shaft while trying to shift.  The dogs don't always drop into place until the gears have moved relative to each other.

Share this post


Link to post
Share on other sites
4 hours ago, turbo dan said:

That could help.  Hold the output shaft stationary and turn the input shaft while trying to shift.  The dogs don't always drop into place until the gears have moved relative to each other.

I do spin the shaft while trying to shift, and it'll get stuck in between random gears, after playing around a bit it'll shift but then it'll happen all over again, everything is spinning correctly and there are no grinding noises or anything, could it have something to do with not having oil although I put tons of assembly lube before re assembling? 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×