Jump to content
Ben Gould

Oil leaking from stator

Recommended Posts

Hi everyone, I rode my crf250 to work, I know these bikes shouldn't be used for road driving, but I thought it would be okay, it was about 20 mimute journey, most roads being 30mph but two being 40mph and 50mph. On returning to my bike after my shift there was a small path of oil and oil on my bashplate, the next day I give it a test run and had the same again, I am 90% sure the oil is comming out of the stator wire grommet, as read another forum on here and kinda similair to my problem.... also is black wire/casasing mean't to have a gap in it like that? 

Thank you very much 

Screenshot_20181021-225647_Video Player.jpg

Screenshot_20181021-225709_Video Player.jpg

Screenshot_20181021-225727_Video Player.jpg

Share this post


Link to post
Share on other sites
17 hours ago, Ben Gould said:

Hi everyone, I rode my crf250 to work, I know these bikes shouldn't be used for road driving, but I thought it would be okay, it was about 20 mimute journey, most roads being 30mph but two being 40mph and 50mph. On returning to my bike after my shift there was a small path of oil and oil on my bashplate, the next day I give it a test run and had the same again, I am 90% sure the oil is comming out of the stator wire grommet, as read another forum on here and kinda similair to my problem.... also is black wire/casasing mean't to have a gap in it like that? 

Thank you very much 

Screenshot_20181021-225647_Video Player.jpg

Screenshot_20181021-225709_Video Player.jpg

Screenshot_20181021-225727_Video Player.jpg

There is a rubber grommet wonder if the crank case is over pressurized like clogged vent tube?

Share this post


Link to post
Share on other sites
4 hours ago, ar2stroke said:

There is a rubber grommet wonder if the crank case is over pressurized like clogged vent tube?

Hi clogged vent tube, totally lost me with this one mate?

Share this post


Link to post
Share on other sites
2 hours ago, Ben Gould said:

Hi clogged vent tube, totally lost me with this one mate?

Is the engine oil and tranny oil separated on this one? 

What is the oil level (is the level correct) just trying to work through the items. 

Share this post


Link to post
Share on other sites

Yes the CRF250X has separate sumps for the engine and gearbox.

 

The engine shouldn't build any pressure in there as it's vented to the airbox and under a slight vacuum.

Perhaps a damaged seal.

Myself added some Yamabond type sealer around that triangular grommet due to it's location 'just in case'.

(debris always getting slung there from the chain)

Edited by mlatour

Share this post


Link to post
Share on other sites
11 hours ago, ar2stroke said:

Is the engine oil and tranny oil separated on this one? 

What is the oil level (is the level correct) just trying to work through the items. 

Engine and tranny oil are seperature yes. The oil level in engine was correct but due to the losing if oil (leak) min now.

Thank you

Share this post


Link to post
Share on other sites
6 hours ago, mlatour said:

Yes the CRF250X has separate sumps for the engine and gearbox.

 

The engine shouldn't build any pressure in there as it's vented to the airbox and under a slight vacuum.

Perhaps a damaged seal.

Myself added some Yamabond type sealer around that triangular grommet due to it's location 'just in case'.

(debris always getting slung there from the chain)

Okay thanks, another guy had the same problem and he did this to fix will give it a try at end of week if not other solutions, do you think take of the casing and have it look inside as will be doing an oil change anyway. Thanks

Share this post


Link to post
Share on other sites

The pics suggest the oil is coming from around the wires rather than from around the grommet, correct?

Any movement if you gently push/pull on the wires?

Share this post


Link to post
Share on other sites
19 hours ago, mlatour said:

The pics suggest the oil is coming from around the wires rather than from around the grommet, correct?

Any movement if you gently push/pull on the wires?

Hi, no movement from wires and I think its is leaking from the wires....

Share this post


Link to post
Share on other sites

A mechanic told me from a video I sent him that the sealant has failed on the stator wiring grommit, he said to take off casing, clean it up and apply new sealer and new gasket.... what do you reckon and how to find out specific gasket type.

Thank you.

Share this post


Link to post
Share on other sites

No gasket type. My recommendation is to remove the case cover and clean the area where the wires go out thru the grommet with spray electrical spray cleaner, contact cleaner, or even  carb cleaner. And then seal the area with a RTV gasket maker. I like red because of its hi temp rating, but blue would probably be OK because the cases don't get too hot.

Share this post


Link to post
Share on other sites
On 11/12/2018 at 1:16 AM, Chuck. said:

No gasket type. My recommendation is to remove the case cover and clean the area where the wires go out thru the grommet with spray electrical spray cleaner, contact cleaner, or even  carb cleaner. And then seal the area with a RTV gasket maker. I like red because of its hi temp rating, but blue would probably be OK because the cases don't get too hot.

Thank you

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×