Jump to content

Help: Can't get Trail Tech Endurance computer to work!

Recommended Posts

Hey need help, have bought a ktm 520 with a trail tech endurance speedo system. Can not get it to work at all cant find much info is there a internal battery if so how do i change it? An should this power the unit back up?

Edited by Allan Butler

Share this post


Link to post
Share on other sites
1 hour ago, Allan Butler said:

Hey need help, have bought a ktm 520 with a trail tech endurance speedo system. Can not get it to work at all cant find much info is there a internal battery if so how do i change it? An should this power the unit back up?

Yes on the battery. Take the unit off the mount and on the back will be a round piece with a slot. Back that off and the battery will be right there. I bought a package of 4 from CVS quite a while ago, can't remember what I paid but they were fairly cheap.

Share this post


Link to post
Share on other sites
16 minutes ago, katoom64 said:

Yes on the battery. Take the unit off the mount and on the back will be a round piece with a slot. Back that off and the battery will be right there. I bought a package of 4 from CVS quite a while ago, can't remember what I paid but they were fairly cheap.

Thanks for that, I'm in Australia an all i had was a downloaded manual with no mention of battery or anything. Then read they have a battery but couldn't find where or how to change, thanks again for the help mate cheers!

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, Allan Butler said:

Thanks for that, I'm in Australia an all i had was a downloaded manual with no mention of battery or anything. Then read they have a battery but couldn't find where or how to change, thanks again for the help mate cheers!

No worries!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×