Jump to content

2017 YZ250F blackish smoke on cold start rev

Recommended Posts

Hey guys 

 

 

picked up a 17 yz250f not long ago with 42 hours on it. A OEM piston kit was installed 2 hours ago, the bike being broken in well i'm getting kind of worried at the sight of smoke out the exhaust on cold start warm up.

Here's what will happen;  I will cold start the bike and everything running fine, after i turn the choke off i'll let it warm up good for 3 to 5 minutes or until the cylinder/rad are warm. Upon giving the bike a small blip of the throttle it will emit a blackish smoke that is sort of thick but only for a second. After the bike is warmed up and hot it does not smoke what so ever. Power is fine and it starts first or second kick out on the track/trail. Is this normal for YZs? I'm a KTM guy so i have no idea about the tendentious these motors have.  Could this just be a bit of oil leaking from the valves that aren't fully warmed up? 

 

Any advice would be fantastic. 

Share this post


Link to post
Share on other sites

Sounds like rich fuel settings...check your ECU maps. But, if if performing the way you want, starting, riding/racing....then leave it as is mate.

Share this post


Link to post
Share on other sites

We pretty much never use the choke on my son's '16 YZ250F -- even on cold days and we aren't very far away from you -- and it always starts fine.  Have you tried starting it without the choke?  Maybe it's just getting too much fuel initially.

Share this post


Link to post
Share on other sites

My 18 WR250F does that on cold starts. It runs extra rich idling until it’s warm and has a lot of carbon/raw fuel in the exhaust. As soon as I blip the throttle it emits one good airy black puff and she’s ready to rip.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×