Jump to content
Sign in to follow this  

Question about an 05 Kinlon

Recommended Posts

 I am only reasonably knowledgeable about this. Trying to gather more information. I clean the carburetor, change the gas and oil, air filter is good new spark plug tested the firing I know it's good. I just got this bike I was told it ran 3 weeks ago, now it doesn't seem to want to kick over. I checked the valves they seem to be good, compressions good, what am I missing? I only got it for my kids to learn to ride on so any help would be greatly appreciated.

Share this post


Link to post
Share on other sites

These tiny little carbs are usually the problem.  The idle circuits are easy to plug and hard to clean out.

You can try a little starting fluid and see if it fires.  If it does then look to the carb for the problem.

Share this post


Link to post
Share on other sites

I actually went and bought a new carb yesterday, put it on tried to check everything, it won't crank. I know it's getting gas, the spark plug is new, new oil, good clean gas. Good compressions, but won't fire. What is the setting for the idle screw? I am Stumped. Feel like I'm missing something. You can smell the gas slightly when I try to crank it. Is it still flooding? Any help would be greatly appreciated.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...