Jump to content

KTM uncomferbly high rev when in neutral and pulling clutch.

Recommended Posts

I’ll try and keep this simple not drawn out, it’s a KTM, 2014 300xc. It idles great when you start it bud if you rev it up it takes it a while to decrease back down to idle. (1-2 sec) when you put it in gear the bike runs as should. Except when I pull in the clutch the revs increase so much it’s hard to shift into gear. (If im standing still) same if I’m riding and I want to pause and take a break, I pull in the clutch and it revs to the moon. It has a recluse clutch in it. 

Share this post


Link to post
Share on other sites
1 hour ago, KRAYNIAL said:

You have an air leak.   When was the last time your replaced the crank seals?

Haven’t, I figured they would last more than 90 original hours. 

Share this post


Link to post
Share on other sites

Could be leaking around the air boot or something? Dirty carb jets?

Share this post


Link to post
Share on other sites
I’ll try and keep this simple not drawn out, it’s a KTM, 2014 300xc. It idles great when you start it bud if you rev it up it takes it a while to decrease back down to idle. (1-2 sec) when you put it in gear the bike runs as should. Except when I pull in the clutch the revs increase so much it’s hard to shift into gear. (If im standing still) same if I’m riding and I want to pause and take a break, I pull in the clutch and it revs to the moon. It has a recluse clutch in it. 

Mine does that when I idle is turned up too high, or when I’m about to run out of gas. I also run the reckluse. It’s a fine line. If I lower the idle too much then what happens is when I’m coming in hot into a corner and pull the clutch lever in it stalls. I’ve become quite good at kickstarting the bike while rolling. So I’m currently installing the jd jetting kit. Still raining around here so I’ll have to get back to you on the performance. I haven’t replaced the crank seals just yet . But it’s probably time.

Share this post


Link to post
Share on other sites
I’ll try and keep this simple not drawn out, it’s a KTM, 2014 300xc. It idles great when you start it bud if you rev it up it takes it a while to decrease back down to idle. (1-2 sec) when you put it in gear the bike runs as should. Except when I pull in the clutch the revs increase so much it’s hard to shift into gear. (If im standing still) same if I’m riding and I want to pause and take a break, I pull in the clutch and it revs to the moon. It has a recluse clutch in it. 
I have the same bike, 298 hrs on it, had the same issue and had to go richer on jets to give it more fuel. Im at 800 to 2400 ft elevation. Also eliminate any possible air leaks. Oh, check needle position, may want to drop clip a notch.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×
×
  • Create New...