Jump to content

Found a piece of a gasket when changing power valve springs. Any ideas? 2008 250 XC

Recommended Posts

 

 

 

It could be the rubber seal that goes around the adjuster screw. It can be torn from what I herd when adjusting the P valve as it tends to stick.

 

At least that’s my take on it.

 

Share this post


Link to post
Share on other sites
 
 
 
It could be the rubber seal that goes around the adjuster screw. It can be torn from what I herd when adjusting the P valve as it tends to stick.
 
At least that’s my take on it.
 

I feel it’s bigger than that... I would hope you’re right though.

Share this post


Link to post
Share on other sites

I feel it’s bigger than that... I would hope you’re right though.

Can you form it around the inside of the power valve adjuster where the springs are.

Do you think it could be an o ring.

Share this post


Link to post
Share on other sites

Can you form it around the inside of the power valve adjuster where the springs are.

Do you think it could be an o ring.


No, it is a paper gasket. And it doesn’t seem to fit anywhere around the power valve adjuster.

Share this post


Link to post
Share on other sites

IMG_0001.JPG

Your attachment didn't post correctly so we can't see it.
 

Hopefully that worked
  • Like 1

Share this post


Link to post
Share on other sites
Where exactly did you find this?


Took off the power valve adjustment cover and it was lying next to the spring. 2008 250 XC.

Share this post


Link to post
Share on other sites

Do you run a Rekluse EXP? It looks like a friction pad off the EXP ring. They feel like 400 wet&dry.

I had the pads come off mine and when I remove the clutch cover and found a bit like your pic, I assumed I'd broken the gasket.

Share this post


Link to post
Share on other sites
Do you run a Rekluse EXP? It looks like a friction pad off the EXP ring. They feel like 400 wet&dry.
I had the pads come off mine and when I remove the clutch cover and found a bit like your pic, I assumed I'd broken the gasket.

Funny you ask I just installed it but only after I found this. It has been installed before though so i will look into it.

As a side question, when I installed the clutch pack it appeared to be missing the first drive plate. So I only have 7 drive plates and 7 friction discs. Is yours like this? Directions say there should be 8 drive plates.

Share this post


Link to post
Share on other sites
Do you run a Rekluse EXP? It looks like a friction pad off the EXP ring. They feel like 400 wet&dry.
I had the pads come off mine and when I remove the clutch cover and found a bit like your pic, I assumed I'd broken the gasket.

I was thinking the same thing but wasn’t sure there was anyway for that to get from point a to b.

Share this post


Link to post
Share on other sites

Funny you ask I just installed it but only after I found this. It has been installed before though so i will look into it.

As a side question, when I installed the clutch pack it appeared to be missing the first drive plate. So I only have 7 drive plates and 7 friction discs. Is yours like this? Directions say there should be 8 drive plates.



Solved. It was one of the pads that came off the Rekluse EXP disk.
  • Like 1

Share this post


Link to post
Share on other sites



Solved. It was one of the pads that came off the Rekluse EXP disk.

Glad to hear although that is good and bad news.

Share this post


Link to post
Share on other sites
21 hours ago, botast said:


Funny you ask I just installed it but only after I found this. It has been installed before though so i will look into it.

As a side question, when I installed the clutch pack it appeared to be missing the first drive plate. So I only have 7 drive plates and 7 friction discs. Is yours like this? Directions say there should be 8 drive plates.

Mine is in a Husky TE310. It uses all the original plates from the clutch pack but comes with a rekluse centre and clutch cover. I know some bikes need plates removed. Best to look on the Rekluse web site for a manual. 

Share this post


Link to post
Share on other sites
14 hours ago, Kwilson405 said:


Glad to hear although that is good and bad news.

Haha, yeah. I had 8 pads come off my EXP disk about 4 months back. Have only found 4 so far.

As a side note. The EXP friction pads do NOT like water. I drowned my bike and had to tow home. Took about a week until I got it started with fresh oil and burned out the moisture. I asked Rekluse what would make the pads come off? They said moisture or excessive heat. I hadn't told them about my wet engine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×