Jump to content
kemerer61

14 300xcw starter

Recommended Posts

I bought a bike with a bad bendix so i replaced the bendix and now the starter carnks but doesnt always start the bike. The battery is giving me 12.9 v off and 14 v running but its a cheap walmart lead acid battery could that be the problem. The bike starts first kick.

Share this post


Link to post
Share on other sites

Are you trying to start it cold with the starter? My 09 (which has a crappier starter than yours) will only fire the bike when it's good and warmed up.

Share this post


Link to post
Share on other sites
Are you trying to start it cold with the starter? My 09 (which has a crappier starter than yours) will only fire the bike when it's good and warmed up.
Warm or cold. Itll sometimes fire after a long section of riding and sometimes wont it doesnt seem to be crancking fast enough but the starters new and the nendix is new

Share this post


Link to post
Share on other sites
21 minutes ago, kemerer61 said:
1 hour ago, Ievko82 said:
Are you trying to start it cold with the starter? My 09 (which has a crappier starter than yours) will only fire the bike when it's good and warmed up.

Warm or cold. Itll sometimes fire after a long section of riding and sometimes wont it doesnt seem to be crancking fast enough but the starters new and the nendix is new

Try a riding buddies battery before you spend money for a new one.

Share this post


Link to post
Share on other sites

Good call

Try a riding buddies battery before you spend money for a new one.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×