Jump to content

Bike won’t start

Recommended Posts

We rebuilt the top end today. Put a B piston in a B cylinder. Put it all together correctly pretty sure. We also changed some stuff in the carb like the floats. We have a spark and gas is getting into the float bowl. We did a compression test and only got 120psi. We don’t know if the tester is bad because it is like 20 years old. The spark plug looks dry when we pull it out, besides the thread on it, but’s I’m assuming that’s just left over stuff from in there. First time we have ever done this sort of work so we don’t know what’s wrong.

Share this post


Link to post
Share on other sites

Are you working on a 2 or 4 stroke? If a 2 stroke the  your reeds may need to be replaced, they're prob worn and not sealing all the and allowing air to get out causing low compression. Also check timing

  • Like 1

Share this post


Link to post
Share on other sites
Are you working on a 2 or 4 stroke? If a 2 stroke the  your reeds may need to be replaced, they're prob worn and not sealing all the and allowing air to get out causing low compression. Also check timing

Sorry ya it’s a yz125
  • Like 1

Share this post


Link to post
Share on other sites

Also if the plug is dry then your not getting gas in it, so spray starter fluid into the sparkplug hole and try starting

  • Sad 1

Share this post


Link to post
Share on other sites
Also if the plug is dry then your not getting gas in it, so spray starter fluid into the sparkplug hole and try starting

That’s what we are going to try next
  • Like 1
  • Sad 1

Share this post


Link to post
Share on other sites

Personally, I'd go back into the carb and blow out the passages and jets. I think the carbs get a weird air bubble sometimes when they're laying on a bench while a rebuild takes place.

  • Helpful 1

Share this post


Link to post
Share on other sites

So we did the starting fluid. It didn’t fully start but towards the end of us kicking, smoke would puff out the tail pipe every kick

We are going to look at the carb again in the morning

Share this post


Link to post
Share on other sites
1 hour ago, Dane Richardson said:

Also if the plug is dry then your not getting gas in it, so spray starter fluid into the sparkplug hole and try starting

Absolutely horrible advice for any 2 stroke, but especially one that’s freshly built. Talk about a good way to instantly ruin a new piston. 

  • Like 2
  • Helpful 1

Share this post


Link to post
Share on other sites

Totally agree with @Bricktop72 ... put down the ether and work on the problem. Did the laws of the universe change and gasoline is no longer highly flammable?  

You probably can't do a good compression test on a brand new top end (rings not seated), but as long as you don't have a gross air lean, the new top end shouldn't be to blame for the no-start condition .      Since you were working on the carb (and you said the the plug looks dry, and you've never done that sort of work) I suggest  you go back in there and double-check your work with the service manual. 

  • Like 1

Share this post


Link to post
Share on other sites
Totally agree with [mention=361834]Bricktop72[/mention] ... put down the ether and work on the problem. Did the laws of the universe change and gasoline is no longer highly flammable?  
You probably can't do a good compression test on a brand new top end (rings not seated), but as long as you don't have a gross air lean, the new top end shouldn't be to blame for the no-start condition .      Since you were working on the carb (and you said the the plug looks dry, and you've never done that sort of work) I suggest  you go back in there and double-check your work with the service manual. 

Ya it never started even with the starter fluid. So no worry. We didn’t spray enough in it anyways for it to possibly start for fear of that and the engine getting stuck. I’m guessing it’s the carb and I’m just gonna go at it tomorrow and tinker with it
  • Like 2

Share this post


Link to post
Share on other sites

Ya it never started even with the starter fluid. So no worry. We didn’t spray enough in it anyways for it to possibly start for fear of that and the engine getting stuck. I’m guessing it’s the carb and I’m just gonna go at it tomorrow and tinker with it

Also I wanted to just see because we made the dumb mistake of doing the top end and carb at the same time so it’s just more hassle to figure out what the hell is wrong with it. Besides looking in the valves in the carb to make sure nothing is stuck in it, what do I do.

Share this post


Link to post
Share on other sites

any chance you put the piston in facing the wrong direction? You made sure the arrow points to the exhaust?

  • Like 1

Share this post


Link to post
Share on other sites
3 minutes ago, bk29 said:

any chance you put the piston in facing the wrong direction? You made sure the arrow points to the exhaust?

Shouldn’t it at least run backwards if you do that  ?

  • Haha 1

Share this post


Link to post
Share on other sites
2 hours ago, Bricktop72 said:

Absolutely horrible advice for any 2 stroke, but especially one that’s freshly built. Talk about a good way to instantly ruin a new piston. 

Absolutely correct. Never use starting fluid in any application regarding what we ride.

Share this post


Link to post
Share on other sites
1 hour ago, AJC1013 said:


Also I wanted to just see because we made the dumb mistake of doing the top end and carb at the same time so it’s just more hassle to figure out what the hell is wrong with it. Besides looking in the valves in the carb to make sure nothing is stuck in it, what do I do.

1. tilt the bike on it's side and see if fuel comes out the overflow tube. When you stand it up, it should stop. Means the floats and float needle are 'working'

2. put in a new plug. Doesn't matter how it looks, you can cold foul a plug no problem

3. if you fail to start it in 10 kicks, you need the clear the cylinder: wide open throttle (wot) and kick through a half dozen times, with the kill button held down

4. very spark is blue and strong

5. verify you have good fuel

6. make sure you are not too rich on the pilot jet. Turn the idle up and the air screw out about two turns when trying to start it

7.try bump starting it

Edited by KRAYNIAL
  • Helpful 1

Share this post


Link to post
Share on other sites

KRAYNIAL has hit everything you need to do. And hell, he's more of a 4 stroke guy. :smirk:

Share this post


Link to post
Share on other sites
4 hours ago, Bricktop72 said:

Absolutely horrible advice for any 2 stroke, but especially one that’s freshly built. Talk about a good way to instantly ruin a new piston. 

The starting fluid would burn off before it causes any damage, it's not going to hurt anything

Share this post


Link to post
Share on other sites
1. tilt the bike on it's side and see if fuel comes out the overflow tube. When you stand it up, it should stop. Means the floats and float needle are 'working'
2. put in a new plug. Doesn't matter how it looks, you can cold foul a plug no problem
3. if you fail to start it in 10 kicks, you need the clear the cylinder: wide open throttle (wot) and kick through a half dozen times, with the kill button held down
4. very spark is blue and strong
5. verify you have good fuel
6. make sure you are not too rich on the pilot jet. Turn the idle up and the air screw out about two turns when trying to start it
7.try bump starting it

Alright thanks

Share this post


Link to post
Share on other sites
any chance you put the piston in facing the wrong direction? You made sure the arrow points to the exhaust?

We have the arrow pointing to the front wheel
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×
×
  • Create New...