Jump to content
Sign in to follow this  

What could be wrong with my yz85

Recommended Posts

So I was riding my yz85 on the street about a week or two back, all was good but I try to ride the street on the next day and when I left my driveway i was going full throttle, shift up, it revved really high (I believe the clutch slipped), so I stomp down to first Incase I hit neutral, turn around to go back try giving full throttle again but it revved really low and gave almost no power, so I just let it roll a little further, gave full throttle again, revved really low and almost did not accelerate at all. After this I shut it off and put it up for the night because it was late and I didn’t feel like riding after that. I have a vid of it but it’s mainly just me talking. The guy I bought it from said he rebuilt it a few weeks before he sold it to me and I mix yamalube 50:1 (gas has been sitting for about s month) so could I be messing something up there? I found almost nothing online about it so I decided to ask here. Please let me know what this could be before I try to do anything with it. Thank you for your help. 

Share this post


Link to post
Share on other sites

Iwouldsaytheengineisblownandyoumightneedarebuild. Howdoesthecompressionfeelonit? Isthereanywaytotestandletusknow? 

  • Like 4

Share this post


Link to post
Share on other sites

Agreed with YZ DOC, you've very likely blown the engine.

 

- street riding a YZ85 (sustained high rpms)

- using a 50:1 premix ratio  (30:1 is what Yamaha recommends)

 

Those are your two first mistakes, the third is perhaps buying it in the first place

as an MX race bike doesn't sound well suited for your intended usage.

You should consider parting it out and getting a scooter instead.

Edited by mlatour
  • Like 2

Share this post


Link to post
Share on other sites
1 hour ago, 2SYZDOC said:

Iwouldsaytheengineisblownandyoumightneedarebuild. Howdoesthecompressionfeelonit? Isthereanywaytotestandletusknow? 

Uh, one period and two question marks? 

No need for that. 

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites

This stuff is getting to be painful. I'm going riding.

  • Helpful 1

Share this post


Link to post
Share on other sites
23 hours ago, 2SYZDOC said:

Iwouldsaytheengineisblownandyoumightneedarebuild. Howdoesthecompressionfeelonit? Isthereanywaytotestandletusknow? 

The compression fells normal, after I put the gas in it i started it up again but it was revving low and just didn’t feel right so I didn’t want to ride it. I’m going to try draining the old gas and changing the spark plug and see if that helps. Any other suggestions of what it could be?

Edited by Helpmecomeupwithagoodusername

Share this post


Link to post
Share on other sites

Remove the exhaust pipe, have a look up the exhaust port at the piston and cylinder wall.

If you see deep scratches and grooves, you've 'blown the engine'.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...