Jump to content
Sign in to follow this  

Radiator cap loose, coolant loss

Recommended Posts

Before riding yesterday I took off radiator cap to check coolant and it was fine.  Put it back on, transported bike to park and noticed coolant on skid plate.  Checked cap, it would feel tight in the first 45 degrees but as it was fully turned on it seems to feel looser, can rock slightly left to right.  Had some coolant loss through the day to where coolant could not be seen through top.   Added when got home did not take much to top up.  Started bike and within a few minutes idling, coolant was coming out overflow tube.  This is 07 and had never lost coolant.  If I had not taken off cap it probably would have been fine.  Not sure what the deal is.  Cap looks ok.  Obviously I'll order a new cap.  Anybody seen similar?

Edited by jpconard
Misspell

Share this post


Link to post
Share on other sites

You sure you turned it all the way?  It should rotate through two tight areas before stopping.

Share this post


Link to post
Share on other sites

Pretty sure, the two "ears" on the cap are in line with the radiator.  Also checked son's 18 RMZ450.  His looks same and I could feel the 2nd tightening area, more on his than on the YZ cap.  The first tightening area is immediate and you pretty much need to push cap down to get past that, then it is looser, then it gradually goes tighter until it hits the stop.  I bent the two tabs on the cap down slightly (towards the top) to make it have a tighter fit, seemed to help.  Went around driveway and street a little slowly and no puking up coolant.  Just weird, never been an issue type of thing.  I'll get new cap, but probably one same pressure or a little more.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...