Jump to content

2016 WR450F backfiring/glowing header

Recommended Posts

Hello again,

I recently bought a 2016 WR450F with a Yoshimura RS-4 exhaust. I noticed that on flat ground at steady throttle, I get some misses and backfires. Is this normal? I did some reading and it sounds like it could be the TPS. I figured it was a clogged injector so I have been running seafoam through it. I did put the stock exhaust back on and had the same issue, so I have ruled out the slip on as the issue.

I also noticed last night that in the dark, the header was glowing red. It is not nearly bright enough to see during the day, but at night with no other light I could see it glowing. I've also noticed that my left leg gets very hot if I don't have my riding boots on. (this has the reversed engine with the exhaust coming out the back and wrapping around the left side of the bike). Is it because the bike is lean from the factory, a clogged injector, or other issue? Or, is this normal?

I just want to make sure that neither of these things are major issues that are damaging my engine as I run it. 

Thanks,

Dan

Share this post


Link to post
Share on other sites
10 minutes ago, SteveThe Snakes said:

If it has the stock ECU you need to put the gytr one in it. 

It does still have the stock ECU. I plan to put the gytr in it to open it up. Is that the core cause of these issues or is there something else going on?

Share this post


Link to post
Share on other sites
1 minute ago, Dan_L said:

It does still have the stock ECU. I plan to put the gytr in it to open it up. Is that the core cause of these issues or is there something else going on?

Can’t know for sure. If the bike sat awhile the injector could be partially plugged. 

Share this post


Link to post
Share on other sites

the glowing header is somewhat normal. to an extent. if you're wearing shorts and tinkering in the garage you will definitely feel the heat from the header pipe which is normal. that's why most moto pants have the leather patch on the inside portions of the legs. 

 

the GYTR tuner will help with the backfire issue. having the aftermarket pipe I would try to find someone with a similar setup and see which map they are running. I'm sure one of the FMF style maps will work just fine also

Share this post


Link to post
Share on other sites

Update. I installed the GYTR ECU and remapped and all issues cleared up. No more glowing header, no backfire, no bog. 

  • Like 3

Share this post


Link to post
Share on other sites

thanks for posting back with an update! hopefully helps some other readers in the future 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×
×
  • Create New...