Jump to content

Pw80 mystery

Recommended Posts

Hey guys new to this website so sorry if this is posted in the wrong place but I have this 96 pw80 that I just rebuilt the top end on its running now but has no power at all like can hardly get out of its own way I tried cleaning the carb changing the air filter and the spark plug I know these bikes aren’t fast but it’s not even as quick as it used to be 

785302E9-AA71-4A3E-945E-0004C4CEDE83.jpeg

Share this post


Link to post
Share on other sites

I don’t know if this applies to the PW80 but the PW50’s and JR50’s have a restrictor plate (basically a fender washer) between the engine and exhaust that limits the exhaust flow. It one of the 1st things people typically remove 1st. Perhaps check if your bike has one also.

 

Share this post


Link to post
Share on other sites

Just did a google search and apparently the PW80 does too. If you do a google search for “PW80 restrictor plate”, you should find some videos telling you how to remove it.

Share this post


Link to post
Share on other sites
2 hours ago, CRF James said:

Just did a google search and apparently the PW80 does too. If you do a google search for “PW80 restrictor plate”, you should find some videos telling you how to remove it.

I took of the exhaust and cleaned the crush ring and where the exhaust bolts to the cylinder with a wire brush and was able to get the ring to sit flush when I bolted the exhaust back on  and it runs  good now I guess it just didn’t have any back pressure from it having a lot of soot and not being able to seal correctly  rookie move on my part I should of cleaned the surface before assembly but thank you for the help 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×
×
  • Create New...