Jump to content
Dante Corona

2008 Suzuki LTZ 400

Recommended Posts

Hi everyone. My LTZ 400 has an oil problem, It is sucked in to the Crank case but it does not return to the reservoir. The retun hose is clear It could be running on iddle for an hour with no problem but as soon as I accelerate the oil stops circulating and the reservoir gets emptie. To much oil ends at the air filter. I know blow by or Bad rings could cause this, but what about the oil stucked inside the Crank case? Could a failure oil check valve be involbed on this. All coments are welcome. Thanks...

Edited by Dante Corona

Share this post


Link to post
Share on other sites

Why oil stays inside the Crank case and won't come out to the reservoir, some oil ends at the air filter. I know Bad rings cause blowby but what about the oil stucked at the motor, all hoses are crlear. 

Share this post


Link to post
Share on other sites

IMG_20200210_121039601.jpg.c2cb15f606618c0e23a424f686c5c7e1.jpg

On 2/5/2020 at 8:27 AM, Dante Corona said:

Why oil stays inside the Crank case and won't come out to the reservoir, some oil ends at the air filter. I know Bad rings cause blowby but what about the oil stucked at the motor, all hoses are crlear. 

I decided to finaly Open My motor apart since no one had an idea about My problem. This is what I've found. Carter filter completely clogged.

IMG_20200210_121027109.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...