Jump to content

Recommended Posts

My 2015 sfx 350 will not start. It turns over but won’t fire. Checked spark, fuel, timing, valve spacing all good and within tolerances. HELP!!

  • Like 1

Share this post


Link to post
Share on other sites

It quit while I was riding. Bogged down and sputtered out. Hasn’t started since. 

Share this post


Link to post
Share on other sites

Does fuel pump turn on when you bump the start button? Check in line filter? Need details. 

Share this post


Link to post
Share on other sites

Ok, pump might not be pumping enough? If I spray fuel into the cylinder it runs. Took the injector out and it sprays fuel. 

Share this post


Link to post
Share on other sites

It definitely runs when I hit the start button. When I spray fuel directly into the cylinder it runs. I pulled the injector out and pushed the start button and it sprays fine. Haven’t checked the pressure. Don’t have the means. 

Share this post


Link to post
Share on other sites

In my experience the injector can appear to be working but be bad.  You might want to buy one and try it...

Share this post


Link to post
Share on other sites

Put a new OEM fuel pump unit in and fired right up. HURRAY....... no, next ride 4 hours in, we stop to let our bike cool off a bit and guess what! My bike won’t start. Doing the same thing all over again. 

Share this post


Link to post
Share on other sites

sounds like an injector that is cooking out.  That or the fuel filter getting clogged?  Also, I presume you have swapped the gas out to make sure you are running fresh gas?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×
×
  • Create New...