Jump to content
SlowRZ97

Drz stator install starter issues!!

Recommended Posts

Hey everybody im at a loss here about whats going on with my bike. I installed a new rickey stator in her but now i cant get the starter to engage/spin. I have a viedo i took and ill post it here. Not really sure whats wrong maybe wireing or i put something in backwards. Any help is welcomed!! 

Starter Problem Video (sorry its in vertical)

 

Share this post


Link to post
Share on other sites
Posted (edited)

Did it work before?

Is your battery fully charged?

Does the motor spin if you take the stator cover off ie is it binding on the stator cover?

Edited by GuyGraham

Share this post


Link to post
Share on other sites
11 hours ago, GuyGraham said:

Have you watched the vid closly, as the idler gear is visible but the motor itself isnt turning

 

yes the idler gear is in there 

Share this post


Link to post
Share on other sites
13 hours ago, GuyGraham said:

Did it work before?

Is your battery fully charged?

Does the motor spin if you take the stator cover off ie is it binding on the stator cover?

the starter did work before install and i charged the battery up all night and its still making the noise

Share this post


Link to post
Share on other sites
17 minutes ago, SlowRZ97 said:

the starter did work before install and i charged the battery up all night and its still making the noise

Take the stator cover off completely and try it

Share this post


Link to post
Share on other sites
1 hour ago, GuyGraham said:

Take the stator cover off completely and try it

will do! i also tracked the sound to the starter relay and im going to test that as well.

Share this post


Link to post
Share on other sites

If the relay is making that noise then chances are its dead and needs replacing

Share this post


Link to post
Share on other sites

Could it be just a bad conscience that the relay goes out right after I swap the stator? It was working decently before. And i measured ohms between the wires and im getting 4.5 ohms so that's in spec but im waiting for my battery to charge to test continuity.

Share this post


Link to post
Share on other sites

The starter relay under the seat is known to fail from time to time.It is either good or bad.Nothing really intermittent about it.Even if it tests bad it didn't have anything to do with your stator and starter clutch repair.

Edited by bumtarder

Share this post


Link to post
Share on other sites
4 hours ago, bumtarder said:

The starter relay under the seat is known to fail from time to time.It is either good or bad.Nothing really intermittent about it.Even if it tests bad it didn't have anything to do with your stator and starter clutch repair.

what if its testing good? it passed the ohm test and i cant jump the terminals with a screwdriver it still just clicks and makes that wrrrrr sound. Im starting to think the relay is ok but im still new to this

Share this post


Link to post
Share on other sites
16 hours ago, bumtarder said:

Are you testing with a known good fully charged battery showing at least 12.7v?

the first few tests i was but then the battery would drain

Share this post


Link to post
Share on other sites

Ok well,you can't do anything unless the battery is fully charged or you jumper from a booster pack or car battery for doing the testing.If you jumper from a car make sure the car is not running or the bike will see full output current from the cars' alternator.

Share this post


Link to post
Share on other sites
Just now, bumtarder said:

Ok well,you can't do anything unless the battery is fully charged or you jumper from a booster pack or car battery for doing the testing.If you jumper from a car make sure the car is not running or the bike will see full output current from the cars' alternator.

ill try that thanks! I also tested the contunity and its showing zero from the relay. That means bad relay right?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...