Jump to content
mark khan

Jet needle suggestions

Recommended Posts

So I got a n7nw needle in my 2000 kx250 at min and I've had to adjust it to the 1st notch runs pretty good at that notch but I'm not sure if I need to adjust it more as I cant lower the needle any more, can some help from the list what would be the best to try next thanks

Screenshot_20200626-180846_Chrome.jpg

Screenshot_20200626-180835_Chrome.jpg

Share this post


Link to post
Share on other sites

If you have it in the first clip position then you need to drop down a size on the main and start back at the third (middle) clip position on the needle again.

Share this post


Link to post
Share on other sites

I've got a 160 main in at min just bought a 155 and a 150 I didnt realize I would have to drop the clip down as I was running good quarter to 3 quarter throttle at top clip and a lot worse at 2nd clip down

Share this post


Link to post
Share on other sites

Sounds like you need to step down to a 158 which would be one step then start at the middle clip position again and adjust from there. The step increments are weird but it goes 160, 158, 155, 152, 150. See the pattern?

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, SS109 said:

Sounds like you need to step down to a 158 which would be one step then start at the middle clip position again and adjust from there. The step increments are weird but it goes 160, 158, 155, 152, 150. See the 

Ah yes I see the pattern👍 so I have the 155 and the 150 here already so was just going to try the 155 so I can at least get out on the bike for a hour tommoro, when I got the bike it had a 165 in it and it felt like it was just not revving up enough and it would be in 5th gear way to quick and have nothing left, I found the flapper of the power valve in the exhaust so cleaned, and rebuilt the valve back up and put in a160 see if that would help, still feels like theres just no kick at the top and you have to change gear to early  it feels like its runs out of gear, way to early I'm in 5th full in every gear same distance my son on his kx100 is in just hitting 4th gear

Should there be a obvious diffrence when the pv kicks in all my previous bike were pre 2000 and when Pv kicked in you defo knew about it.

So to try this 155 while I wait for a 158 still 3rd clip or maybe be 4th down?

Also where does the power jet come in to play?

Edited by mark khan

Share this post


Link to post
Share on other sites

Oh, yeah, you should definitely notice when the power valve opens up.

Nothing wrong with the trying the 155. I would do the middle clip. Who knows, this might be the main jet you actually need! Just pay attention for a lean hang when chopping the throttle. If it hangs then you are too lean and should try the clip in position 4 or 5 and see if it goes away. If not, you'll need the 158. If no lean hang then go to position 2 and then 1 and see how it performs.

The power jet normally kicks in at about 3/4 throttle up to wide open. Some bikes need the power jet changed but I have never known of anyone needing to on the KX250. Maybe someone more knowledgeable on that particular year knows if the power jet was commonly changed to get better overall jetting. I know on the '03 I never needed to change it not even after making it a 265 big bore.

Share this post


Link to post
Share on other sites

I tryed the 155 in the middle seemed ok so tryed it in clip 2 and was a lot better but still seems like theres something missing at the top, I pulled the cover where the rod and wheel for the power valve are behind the exhaust and revved the bike but there was nothing moving, i pulled on the wheel and all moved smooth and the rod from the bottom end sprung it back.

What symptoms would i get for a to small main and to large main? And if the power yet is for 3 quarters to full like the main would that not affect the main

 

It's getting there it's about 80% right just I've never jetted before and a week ago it wouldnt rev at all.

Share this post


Link to post
Share on other sites

If nothing was moving on the power valve then you need to fix that before messing any more with the jetting. It should move if you rev it up. Sounds like it's probably broken off the pin that engages the governor. Part # 13236-1266.

Untitled-1.jpg.7ef27e342c8c8aaf5d18df1a360d972b.jpg

Share this post


Link to post
Share on other sites
14 minutes ago, SS109 said:

If nothing was moving on the power valve then you need to fix that before messing any more with the jetting. It should move if you rev it up. Sounds like it's probably broken off the pin that engages the governor. Part # 13236-1266.

Untitled-1.jpg.7ef27e342c8c8aaf5d18df1a360d972b.jpg

Ye thanks for that would you still feel the spring resistance on the rod if that part has snapped, going to take it apart tommoro.

Share this post


Link to post
Share on other sites

No, you shouldn't but if it's not moving the rod then something down there is broken, damaged, or missing. The governor is what moves the power valves. Come to think about it, it probably isn't that part. It's probably something wrong with the governor or the gear that drives it.

Share this post


Link to post
Share on other sites
43 minutes ago, SS109 said:

No, you shouldn't but if it's not moving the rod then something down there is broken, damaged, or missing. The governor is what moves the power valves. Come to think about it, it probably isn't that part. It's probably something wrong with the governor or the gear that drives it.

👍

Share this post


Link to post
Share on other sites
On 6/29/2020 at 6:57 PM, SS109 said:

No, you shouldn't but if it's not moving the rod then something down there is broken, damaged, or missing. The governor is what moves the power valves. Come to think about it, it probably isn't that part. It's probably something wrong with the governor or the gear that drives it.

There was no  all bearings in it

Share this post


Link to post
Share on other sites
1 minute ago, SS109 said:

Well, that would explain the issue. Now, where did all those ball bearings go?

Have no idea looked every where looks like case been of recently as some of the case bolts were not exactly right and with the state of the guide I'm thinking they got stuck so some 1 took them out

20200630_131804.jpg

Share this post


Link to post
Share on other sites
1 minute ago, SS109 said:

Wow, that thing is pretty worn. Might be worth it to pick up another whole governor off ebay or something.

Just ordered the bearings and smoothed it out see if that works but if not will have to as that guide not avalible to buy now

20200630_205133.jpg

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...