Jump to content

WP Open Chamber Help

Recommended Posts

Hi everyone, I'm replacing the seals on my Open Chamber forks (4 pin style) got everything back on but I can't get the compression nut on the bottom to tighten. It just spins. Got it started by hand then tried spinning it with an impact and it's not tightening up. Was wondering if it will hold oil just finger tight then I could try to tighten again once the oil and spring is installed? Got pissed that the video makes it look so easy then I get screwed so I took a break. Can anyone give me some pointers? Thanks. 

Edited by Muffintop

Share this post


Link to post
Share on other sites

Pull the assemble back out and clean up all the threads so it'll screw all the way down with your fingers, then try again. Otherwise, if you're 100% sure the threads are good, just throw the spring in and compress it to hold it while you tighten the nut. Only takes a minute or two to fit the spring.

Share this post


Link to post
Share on other sites

Yes. You have to have the spring in and assembled, and compress the fork alot with a tie down strap, to tighten the bottom bolt. Impact gun lightly to get it snug then torque wrench.

Share this post


Link to post
Share on other sites

Thanks fellas, I appreciate it. I'll give it a shot in a little bit here.  🤠

Share this post


Link to post
Share on other sites

So I got it back together and it seems to be nice and smooth. Are you supposed to be able to hear the spring a bit if you shake the fork? Maybe I hadn't noticed before I took it apart. Also I attached a pic, is that part beneath the threads just the spring preload adjuster that's all the way out?

IMG_5775.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×
×
  • Create New...