Jump to content
Pooc40

YZ250 2004 YZ250 Idle knock with fresh top and bottom end rebuild

Recommended Posts

2 minutes ago, Sullysully said:

I think so, I’d have to check my manual. Even if it’s .01in it’s not meant to be “impressive” just whatever the manual specifies. There are some skilled rebuilders that can get zero runout.

I realize that it's just a spec, was more commenting on .01in being pretty large for a runout measurement. Useless comment really in retrospect as the manual almost always specs in metric.

Share this post


Link to post
Share on other sites
10 minutes ago, Pooc40 said:

I realize that it's just a spec, was more commenting on .01in being pretty large for a runout measurement. Useless comment really in retrospect as the manual almost always specs in metric.

I think mine gives both for certain things. Like ring end gap.

Share this post


Link to post
Share on other sites
3 minutes ago, Sullysully said:

I think mine gives both for certain things. Like ring end gap.

Probably true.... guess I just normally pay attention to the metric side! Haha

Share this post


Link to post
Share on other sites

One of the guys I ride with has a KDX and it sounds just like that if not louder at idle -1/4 throttle open. I know on those bikes it is the power valve system. Once you speed the engine up the sound dissipates on his though. Keep us up to date what you find out.

  • Like 1

Share this post


Link to post
Share on other sites

just put in new Hotrods crank, bearings, seals and vertex B piston in my 06.  Sounds nothing like that.  Something is hammering away causing the knock. 

Share this post


Link to post
Share on other sites
11 hours ago, cmstbcchamp07 said:

One of the guys I ride with has a KDX and it sounds just like that if not louder at idle -1/4 throttle open. I know on those bikes it is the power valve system. Once you speed the engine up the sound dissipates on his though. Keep us up to date what you find out.

KDXs have what’s known as a KIPS rattle. Kawasaki thing.

  • Like 2

Share this post


Link to post
Share on other sites
9 hours ago, JJRace said:

just put in new Hotrods crank, bearings, seals and vertex B piston in my 06.  Sounds nothing like that.  Something is hammering away causing the knock. 

I just figured I would have found something significant by now, seeing as I've torn it down twice. But I definitely agree it can't be normal. Powervalve was definitely worn, shaft has some play up and down when installed.... also does anyone think advanced or retarded timing could cause this? I know my stator timing is on but I'm wondering if the tps could malfunctioning or be set wrong.

Edited by Pooc40

Share this post


Link to post
Share on other sites
2 hours ago, Pooc40 said:

I just figured I would have found something significant by now, seeing as I've torn it down twice. But I definitely agree it can't be normal. Powervalve was definitely worn, shaft has some play up and down when installed.... also does anyone think advanced or retarded timing could cause this? I know my stator timing is on but I'm wondering if the tps could malfunctioning or be set wrong.

I highly doubt this is TPS.  It only comes into play for timing at very high rpm to retard and allow more over rev to my knowledge.  You can disconnect the TPS and your bike will run just fine if you want to double check.  It sounded mechanical to me and directly inline with rpm.   

Share this post


Link to post
Share on other sites

you need to get together and figure out the issue:

 

 

something is hammering away.  If not the crank & bearings, then maybe wristpin and top end bearing, or maybe the power valve piece or something else that is connected directly to the crank or crank gear. 

Share this post


Link to post
Share on other sites
11 minutes ago, JJRace said:

you need to get together and figure out the issue:

 

 

something is hammering away.  If not the crank & bearings, then maybe wristpin and top end bearing, or maybe the power valve piece or something else that is connected directly to the crank or crank gear. 

Seems unlikely that it's in the rod or wristpin bearing as I've checked those three times each. When I attempted to isolate the sound it was loudest from the top of the top end, like the bulge at the rear of the cylinder. Will do some more testing tonight if I can remember to bring tools home from work.

Share this post


Link to post
Share on other sites

I’m really curious about if it’s the head clearance. I had an Athena cylinder and head on an 03 motor, and it needed 2 base gaskets or the piston would hit the high compression dome. The squish was bananas

Edited by Sullysully

Share this post


Link to post
Share on other sites
10 hours ago, Sullysully said:

I’m really curious about if it’s the head clearance. I had an Athena cylinder and head on an 03 motor, and it needed 2 base gaskets or the piston would hit the high compression dome. The squish was bananas

I'll check squish in a few, here's the sound w/ more rev 

 

Share this post


Link to post
Share on other sites
15 minutes ago, Pooc40 said:

I'll check squish in a few, here's the sound w/ more rev 

 

 

check this out. I was messing around on YouTube and listen to this older bike. These guys deal on top of the line vintage bikes a lot. Usually pristine/restored. Listen to it

Share this post


Link to post
Share on other sites
16 minutes ago, Sullysully said:

 

check this out. I was messing around on YouTube and listen to this older bike. These guys deal on top of the line vintage bikes a lot. Usually pristine/restored. Listen to it

It definitely does sound similar. Mine is just so loud on that decel when it shows up. It does seem tied to revs, but definitely dissappears above a certain rev.

Share this post


Link to post
Share on other sites
23 minutes ago, Pooc40 said:

It definitely does sound similar. Mine is just so loud on that decel when it shows up. It does seem tied to revs, but definitely dissappears above a certain rev.

Kinda the same on that bike. They may be different years, but 2 strokes are fundamentally the same. Plus phone cameras seem to accentuate sounds. We might have been wasting our time here 

Share this post


Link to post
Share on other sites
59 minutes ago, Pooc40 said:

I'll check squish in a few, here's the sound w/ more rev 

 

Watching your kick starter jumping while it was running and revved makes me wonder if something in the starter gear is making your noise? This is a different engine but something to check. Good luck with it 👍

 

Share this post


Link to post
Share on other sites
7 hours ago, Pooc40 said:

I'll check squish in a few, here's the sound w/ more rev 

 

That one almost sounds normal. The sound is absolutely normal it just seems louder. At rev sounds good so I'm wondering again if it's not just your camera isolating that noise.

Take a long dowl rod or screw driver and put it to your ear and move it around to different spots on motor while running, you'll be able to isolate where it's coming from atleast

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...