Jump to content

cylinder weep hole leaking oil

Recommended Posts

hey everyone i’m new and thought i would give this a shot to see if anyone could help me. i have a 2011 kx 450 leaking oil from cylinder weep hole. i replaced the spark plug gasket under the valve cover but it still leaks. could it be the o ring under the cam caps? oh and when i went to replace the spark plug gasket there was about an inch of oil in my spark plug cavity. i vacuumed it out took off valve cover and replaced gasket. still leaking please help. also does anyone know spark plug socket size i tried 5/8 but it’s a little small. sorry for the long type

Share this post


Link to post
Share on other sites

There’s the plastic cap on the spark plug well and an Oring in there too. 

Share this post


Link to post
Share on other sites

the one i replaced under the valve cover was rubber not plastic it was a circle with like a lip on each side

Edited by Chris Stewart

Share this post


Link to post
Share on other sites
On 7/8/2020 at 8:51 PM, Chris Stewart said:

the one i replaced under the valve cover was rubber not plastic it was a circle with like a lip on each side

On my 06 the o ring under the cam bridges is the one that is the problem maker for leaking oil out the weep hole. I've replaced it a number of times.  I prettty sure it's the same design. 

Share this post


Link to post
Share on other sites
19 minutes ago, Chris Stewart said:

hey thanks for the reply. do you take your cam chain tensioner out or just screw it all the way to the right?mine is just a drop here and there. hardly noticeable i just can’t stand it lol would you worry about it ?or should i just replace it when i do a top end rebuild in a couple months 

If it's just a drop now and again maybe not. Did you say earlier your spark plug cavity was full? If that keeps happening I would fix it.  Yes I just loosen cam chain up from screwing the interior of the cam chain tensioner and lift up the cam bridges enough to slip a new o ring in. And if nothing moved it doesn't need retimed.

Share this post


Link to post
Share on other sites

yeah it was ridiculous how much oil was in the cavity but since i replaced the gasket under the valve cover it hasn’t pooled up... yet . i’m gonna ride a couple more times and check again. waiting on my torque wrench now. thanks for the advice man

Share this post


Link to post
Share on other sites
11 hours ago, Chris Stewart said:

yeah it was ridiculous how much oil was in the cavity but since i replaced the gasket under the valve cover it hasn’t pooled up... yet . i’m gonna ride a couple more times and check again. waiting on my torque wrench now. thanks for the advice man

Ya no problem. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×
×
  • Create New...