Jump to content
smv ryder

2020 FX 350 build

Recommended Posts

The bike was made to run the hand guards directly mounted to the brake and clutch perches, why I am saying that is the Acerbis X- force hand guards are just not made to work on this bike. They just make all my controls wanky AF! I know I just said no more parts but hand guards and all the controls being right is worth it. So I am giving the Acerbis K- Future hand guards a try.  Yes I have the stock hand guards but JC they are terribly ugly.
https://www.acerbisusa.com/p146101-k-future-handguards?uid=146101%3Acolor%3D%2388563f%2C%2B%23ffffff

Share this post


Link to post
Share on other sites

So I just can’t keep things alone...
1. Titanium motor mount kit
2. Bought some more titanium bolts/screws 
3. CMT  COMPOSITI engine mounts...very stoked on these
4. Racetech bladder conversion in black.

Share this post


Link to post
Share on other sites
12 hours ago, weantright said:

And I thought my bikes were expensive!

You have more bikes than me so you have to spread the love around, I couldn’t imagine if you had just one bike.

I sure do loath the USPS, 99.9 % sure they lost the titanium bolts. Pretty bummed 

 

I really wanted to have all parts installed before Moab this weekend, we will see....

  • Like 1

Share this post


Link to post
Share on other sites

Where's the stx rims,the stock rims on my mine got bent right off.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, galligar said:

Where's the stx rims,the stock rims on my mine got bent right off.

The spokes into nipple is the real problem with stock Husky wheels. I have STX rims and still bent the rear. My 2020 250xc wheel set are the worst I have seen in a long time. 95% of the spokes were finger tight at 10 hrs. Rim has a dent and the front needs trueing. I have them on my spare bike because they have tires on. Otherwise they would on the shelf and replaced with Husqvarna’s. 

  • Helpful 1

Share this post


Link to post
Share on other sites

the giant rims on my 20 fe were junk, and you can break anything. I've had did stx rims on all of my recent bikes 13,15,17 crf450s and fc450 no trouble, spokes stay tight . Faster USA built my wheels.

  • Like 1

Share this post


Link to post
Share on other sites

Faster USA did my wheels also. Great company and I learned a lot from them just how bad OEM wheels are. 

  • Like 1
  • Helpful 1

Share this post


Link to post
Share on other sites
On 10/26/2020 at 6:12 AM, weantright said:

And I thought my bikes were expensive!

I am a special type of weird. 
99% sure I will pull the trigger on the KYB kit next week after Moab, as much as I want to do DLC on the fork lowers I think I am going to skip it. Saying that I sure do love Redbull and Vodkas on vacay, so maybe I convince my self in Moab.. lol 

Share this post


Link to post
Share on other sites
On 10/27/2020 at 7:43 PM, Piney Woods said:

Never ever never trust the usps, ever never! Have a great trip!

I never do but sometimes shippers go the cheaper route for shipping and just shit on me. I am beyond stoked after begging to search for my bolts they found them!! Holy heck I am so stoked.

locked and loaded for Moab!!! Picking up a Nice Yamaha waveblaster 1 that a dude is delivering down from Provo to us in Moab. That’s why the jet ski trailer is hooked up. 

8D313F8F-201B-4F16-97E4-BC1B7D70C542.jpeg

Share this post


Link to post
Share on other sites

I made a big old dummy mistake . The CMT carbon fiber engine mounts that I bought are stuck in Memphis Tennessee FedEx. They have been there since Saturday and I just discovered I put the wrong zip code, they couldn’t ship to my small ski town but my wife’s bank down valley they could and I forget to change the zip code . I have been trying to hit up CMT constantly but they are in Italy and have not wrote me since I wrote Friday night. I got 3 emails in, IG messages and even posted on their with in one day IG posts. Praying I get them but it was my mistake but I have been begging them to change the zip code on their end.

fingers crossed!

FYI this bike is so dang awesome!! It killed in Moab. So stoked 

Share this post


Link to post
Share on other sites

I hopefully fixed the fedex issue, of course CMT didn’t find time to help me.  I know Italy has been through the ringer with COVID so it’s what it is.

So buying the new to me Yamaha waveblaster has put the KYB kit purchase for December. I went a little crazy on parts buying on the waveblaster this month and want to keep the wife happy.  The ski is going to be a ripper for sure and handle awesome AF! 
 

I think it’s time to pull the trigger on a ECU reflash. I usually use Tokyo Mods for the reflash but going with Blais Racing this time.  The vortex ECU is tempting but honestly a reflash will be more than plenty.
https://blaisracingservices.com/2012-2017-ktm-husqvarna-custom-ecu-mapping.html

8C111D13-4B69-4389-B219-ACD6E92D977A.jpeg

1011AF50-CE2B-41C9-812E-8651AEC9764A.jpeg

AF37C00E-F2CF-4E83-A310-406ADDD4C2D3.jpeg

Share this post


Link to post
Share on other sites
30 minutes ago, weantright said:

Bad news is those ski are no fun unless you have two!

Don’t worry my man! My wife was born on a stand up!! This is her Butch Racing prepped Superstock 550 SX, it’s a very rad 550. 

49D03EF9-1A85-47CB-8F5E-876C8B5BE00A.jpeg

398CFE4B-645D-46C0-9B7F-7C920573EDE7.jpeg

00D224DB-5A53-4D7F-920D-1A8FC5528588.jpeg

C5B9C41B-FC20-4909-A7B6-225AF3D440F1.jpeg

  • Like 2

Share this post


Link to post
Share on other sites

So some weird things have came up.. 

1. The bike spits out fuel from the over flow gas tank line quite frequently even riding at 50 degrees.  One thing I will say is I tried to install a Nihilo billet gas cap, it didn’t work and now my OEM gas cap for some reason doesn’t have the push down town and turn button. It just turns like a normal gas some how.., 🤷🏼
 

2. The more concerning thing is the bike has coolant coming out of the over flow tube when the bike is not boiling over. Today was 55 degrees and for some reason I had coolant coming out of the over flow tube, bike wasn’t hot and the radiators were not boiling.. I have a 2.0 cap and the Boyeseen super cooler installed, the tusk fan is waiting to be installed. It started after the Boyeseen super cooler water pump install, did I install the impeller the wrong way?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×
×
  • Create New...