Jump to content

Bike is like rev bombing when it is started

Recommended Posts

For some reason I started it and it just rev bombed I have been looking taking the throttle apart I took the needle out of the carb and it’s still doing it anyone have a idea I’m so confused right now.

Share this post


Link to post
Share on other sites

check the trottle cable end piece that goes into the slide, make sure it is fully seated in the slide or you could have the problem you previously stated. lastly check your throttle cable and make sure it isnt bound up somewhere in the bike. let us know if that didnt fix it

Share this post


Link to post
Share on other sites

there is a little metal piece on the end of the trottle cable that goes through the top of the carb and down into the base of the slide where the needle comes out, if you have a pwk carb it is different, what carb do you have?

Share this post


Link to post
Share on other sites

thank you, now i need you to unscrew the cap on the top of the carb where the cable comes into the carb, after you unscrew it the slide should come out easily while still on the throttle cable, look at the bottom of the slide and there should be a slot for the end of the cable to fit into. if it is in the slot and fully recessed into the slide then it is properly inserted. after trying that i would recommend you make sure you have enough slack in the throttle cable to allow the slide body to rest against the base of the carb. thry my first commendation, if you need a visual representation then i would look on youtube for "pitbike carb slide install"

Share this post


Link to post
Share on other sites

Ok thanks a lot I will check it out and see if it works.

  • Like 1

Share this post


Link to post
Share on other sites

I think the problem is that I don’t have enough cable in the slide. How would I get more?

Share this post


Link to post
Share on other sites

there should be an adjuster on the throttle tube where you can screw it in or out to add or take away slack.

this might help

 

Share this post


Link to post
Share on other sites

Did the thing with the throttle still is really high in rmps

Share this post


Link to post
Share on other sites

either you need a new cable, or you can trim the cable housing down a little bit by bit till it fits, second option can ruin a cable if done poorly, you gave the cable as much slack as possible right? just double checking

Share this post


Link to post
Share on other sites

im talking about where the throttle comes through. see the nob on the outside of the throttle tube.has the black plastic then a metal wheel in the upper leftof the pic, thats where you adjust the throttle slack

Edited by Randy K

Share this post


Link to post
Share on other sites

loosen the metal disc and twist the end farther in to give more slack

Edited by Randy K

Share this post


Link to post
Share on other sites

yah thats it, looks like it is as short as it can get, your going to need to cut the throttle cable housing down a little bit to get that cable to work, there usually is an adjuster on the top of the carb as well that can give you more slack. it is under the rubber bit on top of the carb cap i asked you to remove earlier. if there isnt any slack there then either order a new cale or if your good with tools you can cut the throttle cable tube around the braided cable back a half inch and see if that fixes it. just dont cut the braided cable or your out of luck

Share this post


Link to post
Share on other sites

Ye I’m not very good with dirt bikes externals put man you get me into that motor I’m a expert with that stuff so maybe I will have one of my friends take a look at it it really sucks because I just was riding it yesterday and it was perfectly fine man I just wanna ride and that’s all that goes threw my head out that’s I will let you know if I need anything else.

Share this post


Link to post
Share on other sites

if it worked before then you shouldnt have an issue, maybe rerun the throttle cable and make sure it isnt pinching in the top of the carb, i spray dirtbike chain lube into mine and never have a sticking cable, hope you can have a friend fix it for you man, sorry i couldn't help more

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×
×
  • Create New...