Jump to content
Onzalimey

Desperately need help with my idle bog

Recommended Posts

This is a 2017 Husky TX300. Has a Kiehn carb on it. Same carb my last bike had which was a husky 300 2017 and it ran great on that. I bought the bike off someone and it had a MIkuni on it and still felt dull on the low end. Anyway, it bogs under low RPM load and I cannot for the life of me figure out why. Also the low end power seems not so great. Went from a 35-45 pilot and a few in between. Changes the mixture but the bog doesn't change with any of those jets. Maybe a touch worse with a 35. And it has to have the air screw all the way in or its way worse. Had the carb off, looked clean, float bowl is good. No cracks in either side of the boots that I can see. Just replaced the reeds with V force. Compression feels good on the kickstart and the bike has tons of power in the high rpm. It has a FMF powercore shorty on it and I'm not sure if that would cause issues. Cylinder looks good from visual inspection. Power valve seems to work and is clean. Put a new plug in it. Don't know what else to do.....

Share this post


Link to post
Share on other sites

Silencer has been repacked, jetting has been changed a ton. The bike itself runs much better on good jetting obviously but no matter how rich or lean on all jets and the slide it still will bog off idle. I even put my buddies 300 stock silencer on it and nothing. Seems extremely odd it wants to bog off idle even with good jetting. My buddy is pretty good at jetting bikes and we tried to troubleshoot everything and nothing. Just seems so weird to me.

Share this post


Link to post
Share on other sites
2 hours ago, weantright said:

Is it smoking a lot? Loss of gear oil?

When I went rich it obv smoked lots. But on proper jetting it’s normal 

Share this post


Link to post
Share on other sites

Im having a little trouble understanding your post. You added the Keihin and its bogged since then?  Is it a real carb or a knockoff? Slide cutaway? What needle?

Share this post


Link to post
Share on other sites
18 hours ago, Onzalimey said:

This is a 2017 Husky TX300. Has a Kiehn carb on it. Same carb my last bike had which was a husky 300 2017 and it ran great on that. I bought the bike off someone and it had a MIkuni on it and still felt dull on the low end. Anyway, it bogs under low RPM load and I cannot for the life of me figure out why. Also the low end power seems not so great. Went from a 35-45 pilot and a few in between. Changes the mixture but the bog doesn't change with any of those jets. Maybe a touch worse with a 35. And it has to have the air screw all the way in or its way worse. Had the carb off, looked clean, float bowl is good. No cracks in either side of the boots that I can see. Just replaced the reeds with V force. Compression feels good on the kickstart and the bike has tons of power in the high rpm. It has a FMF powercore shorty on it and I'm not sure if that would cause issues. Cylinder looks good from visual inspection. Power valve seems to work and is clean. Put a new plug in it. Don't know what else to do.....

What slide are your running?  Needle?

Edited by mxaniac

Share this post


Link to post
Share on other sites
1 hour ago, Onzalimey said:

It’s not a jetting issue. Even though it sounds like one. Trust me 

You used this same carburetor on a different 300 and it was jetted correctly?  Was it bogging on the Mikuni or just not jetted as lean as you would like?  If the carb swap caused this then we look at air leaks on the intake boot and dirt in the read block.  If you did the carb swap because the bike didn't run well then we look at:

compression (measure it)

clogged silencer

crank seals

blown head or base gasket

ignition timing

Rag in the air box boot (it's happened).

Try it with the kill button unplugged.

Change fuel

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...