Jump to content
Sign in to follow this  

Losing my compression

Recommended Posts

I have an '03 250F and have noticed that there is alot less compression than what it used to have, i have had the valve clearances checked and adjusted, and have started to leave the bike at TDC when it isnt being ridden since i read to do it in another post, these havent fixed the problem. the decompression plug blew out not long ago and luckily lodged between the radiator hoses so i put it back in so could this be part of the problem, please help if you have some suggestions. :thumbsup:

Share this post


Link to post
Share on other sites

The decompression plug is only used as an oil seal. It's glued in where the 01-02 bikes had the manual decompression linkage mounted.

what is the bike doing that makes you think it's losing compression?

Share this post


Link to post
Share on other sites

when starting the bike the kickstarter goes straight down with hardly any effort, i used to be able to almost stand on it and it would barely move

Share this post


Link to post
Share on other sites

who did the valve adjustments, and was it doing it before they were adjusted?

It could be anything from a worn out timing chain to the valves adjusted improperly to a chipped valve to a hole in the piston to broken rings.

I would chase the valves not being adjusted right first.

Share this post


Link to post
Share on other sites

Your bike probably is need of a new set of rings and most likely the piston is worn past spec, too. The compression hole plug can be blown out from excess ring blow-by.

In any case, you want to get the problem resolved before riding again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×