Jump to content
Sign in to follow this  

Timing Chain problem?

Recommended Posts

hi,

well, being the fool i am, i decided to take a look under the hood of my kxf and see whats what. I have the manual for it and decided to see if I can do the shim thing again, (did it once before but had alot of help from one of my friends that works at a suzuki dealership). anyways, after alot of cursing and whatnot, i did it and lined up the camshafts with the dots and on the 1st, 2nd and 28th pin. it looked good so i put the rest back together and then started it up. I immediatly turned it off for a couple reasons. 1- it started on the first kick which it never does but what scared me even more was that the engine seemed to be making a knocking noise and picked up speed with throttle rolled on. my question is that I know 1 tooth can throw everything off and was wondering if it being 1 tooth off would make this knocking noise. thanks in advance as I am also learning with time. TT has been awesome to me so far! :devil::thumbsup:

Share this post


Link to post
Share on other sites

sounds like to me you did not undo the tensioner on the cam chain. check to see if thier is tension on the chain and the tensioner is not stuck. that might be the noise why it is knocking , but if all the dots line up you have it timed.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×