Jump to content
Sign in to follow this  

Over-shifting Problem...

Recommended Posts

A couple months ago my bike developed a problem where it would downshift from third past second and into neutral randomly. I'd taken it apart and everything looked normal. I replaced second gears, shift fork, drum, and most of the shift mechanism but the problem persists. Has anyone had this problem or can shed some light on what it might be?

Share this post


Link to post
Share on other sites

Not trying to contribute to the hysteria surrounding this bike but just wanted post this info in case anyone else ends up having this problem.

After splitting the cases twice and tearing into the primary three times I finally fixed this annoying little shifting problem I've been having for the last several months. I had replaced second gears, shift fork, drum, most of the shift mechanism and welded the shift shaft with no affect on the problem whatsoever. Using the power of deduction (ok... desperation) I welded a glob of metal to the drums detent arm to increase the load on the spring. Presto! motor bike now shifts perfectly.

A couple of side notes after 11 months of heavy thrashing of this bike: my cam chain stretched enough to allow me to rotate the intake cam back one tooth so that the marks line up perfectly now. Also, internally my motor is in great shape. Only had to adjust one valve after two rides and still no change since then.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×