Jump to content
Sign in to follow this  

Clutch problems

Recommended Posts

I'm having a problem with my clutch I think and was hoping for some help.

Here's the problem.

When I'm on the gate and waiting for it to drop I start to let out the clutch until it starts to engage, only instead of slightly engaging it jumps forward. It seems to be worse at high rmp's, like a start, rather than when I just idle away.

I'm thinking it's my basket thats worn.

If so I'd probably buy a hinson basket. Do I need both the inner and outter basket? What about pressure plate?

What about the cushions? I'm not sure if I should buy the hinson basket with cushions or can I use the ones on there now?

And one last question, where can I buy the gear holder?

Thanks for any help.

Share this post


Link to post
Share on other sites

checkout the TT store for prices on the Hinson clutch kit. You really need to tear down your clutch and actually see what kind of wear you have and post some pics on here. You should be able to get the gear puller at the TT store as well.

HTH :cry:

Share this post


Link to post
Share on other sites

I've taken it apart now, but my attempts to take a picture did'nt go over to well. They came out to blurry to see anything. I'll have to read my camreas manual tommorrow to find out of to zoom in that close.

There are some small groves in the basket, but I'm not sure how much these affect anything. Are very small groves normal? Would you think this is my problem?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×