Jump to content
Sign in to follow this  

need help water pump weep hole

Recommended Posts

coolant is coming out of the weep hole of the water pump when ever the bike is started, dont know what the prob is. looked in the manual and couldnt find anything. :cry:

Share this post


Link to post
Share on other sites

If you replace the seal and it keeps leaking check the counterbalance shaft bearing. The counterbalance shaft drives the water pump. If that bearing goes bad the shaft can wobble a bit. The seal will leak if that happens. I had the problem on my '02, '03, and '04.

Share this post


Link to post
Share on other sites

Mine was doing the same thing. I took it apart to look at the seal, and it had some junk in it. I cleaned the parts up and put it back together and haven't had a drop of fluid come out since.

Now, the only question is how did something get in there..

Share this post


Link to post
Share on other sites

10 bucks says its the seal, if nothing else is wrong with the bike. :cry:

no the reason it leaks is the pump shaft is wearing down smaller than the seal.(look at the shaft for a small grove in it) but you need to replace the seal and the shaft to.

Share this post


Link to post
Share on other sites

if that were the case i would be on my 4th shaft.last seal i changed out was around early spring. :cry:

I agree. I changed my outer seal only about 1 1/2 years ago and it's been fine since.

Share this post


Link to post
Share on other sites

Just bought an 03 and mine is doin the same thing... my 86 cr 250 did the same thing. I replaced both the oil and water seal and it was fine.... though it took 15 yrs. for the 86 to leak! I'm also replacing the shaft on the 03 450, it has a groove in it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×