Jump to content
Sign in to follow this  

Still problem /bike dies

Recommended Posts

Got to ride today still have problem with bike dieing and hard to start afterwards. Did it rolling up to stop sign on flat. Seems to happen after 20+ miles. Have checked valves, vent tubes, drained float bowel, changed plug. What to check next?

Share this post


Link to post
Share on other sites

Problem happens when bike is hot some times letting it set 10 min. starts and runs fine. Rode for 3hrs today did it 3 times on level ground. Real hard to guess whats happening.

Share this post


Link to post
Share on other sites

ok,next time it quits open the float bowl drain.see if its full of gas.

if it is,it sounds like a eletrical issue.

stock tank?ive seen plastic shavings from plastic tanks wrap themselve around the fuel pickup.

Share this post


Link to post
Share on other sites

Does have plastic IMS tank. Will do float bowel drain next time. Thanks Burned Wont get to ride untill next weekend. Will try to pull tank off and check this week

Share this post


Link to post
Share on other sites

All the IMS tanks I have seen come about 1/2 full of plastic shavings. Sounds like burned hit it again. Who installed the tank? Did the installer clean the tank?

Share this post


Link to post
Share on other sites

Was a used tank and I rinsed it out when I installed it a year ago. but it is worth a look anyway. Any thoughts are welcome Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×