Jump to content
Sign in to follow this  

dust coming in thru hot start cable

Recommended Posts

I took the top off my carb to clean the slide and it was obvious that I'm sucking dust in thru the hot start mechanism. There was dust caked around the hole and even a spot on the inside of the top cover where it looked like dust was spraying out of the hole so forcefully that it formed a pattern of collected dust. The hot start cable and mechanism are installed correctly and nothing is loose. Anyone else seen this? Is it normal?

Share this post


Link to post
Share on other sites

It's normal for dust and corrosion to accumulate on the carb end of the cable. Just maintain is by cleaning and add a dab of light oil to the carb end on a routine basis.

Share this post


Link to post
Share on other sites

It's normal for dust and corrosion to accumulate on the carb end of the cable. Just maintain is by cleaning and add a dab of light oil to the carb end on a routine basis.

I was just alarmed at the sheer volume of dust and the apparent velocity with which it appeared to be entering the carb, especially considering that I rarely use the hot start lever.

Share this post


Link to post
Share on other sites

It will leak in dust and water no matter what you do. Clean it out with carb cleaner once a month. To lube it, you have to be careful with what you use, as you don't want anything that can run into your carb. With the cable off, of course, I lube it with a dry-film teflon based chain lube like the Honda chain lube, let it dry, then install it again.

Share this post


Link to post
Share on other sites

It will leak in dust and water no matter what you do. Clean it out with carb cleaner once a month. To lube it, you have to be careful with what you use, as you don't want anything that can run into your carb. With the cable off, of course, I lube it with a dry-film teflon based chain lube like the Honda chain lube, let it dry, then install it again.

sounds good. What about just packing a clean paper towel or two underneath the hot start hole inside the top of the carb? Seems like you could flush the cable with carb cleaner, then lube it and let is sit for a while without removing the unit from the carb, or is it not that big a deal to take it off?

Share this post


Link to post
Share on other sites

Just take it out. Of coure you gotta take off your seat, tank, etc., but the hot start cable just screws right out. Then you can scrub out the hole in the carb with an old toothbrush.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×