Jump to content
Sign in to follow this  

04 crf450 throttle stiff

Recommended Posts

Anyone out there know what causes the throttle to become hard to turn on the 450s over time. My buddies 03 did it and he tried everything to get back the original feel. Cleaned bar and housing, motion pro cables, etc., but no luck. Now my 04 is starting to do the same thing, and I've tried the usual stuff with cleaning and lubing in the housing and cable area with no change. Is it in the carb? :cry:

04 crf 450

applied racing 22mm clamps

Share this post


Link to post
Share on other sites

Craig, the answer is simple...buy a 05.

Sorry buddy had to give you a hard time....Doug

Share this post


Link to post
Share on other sites

I had a similar problem with mine caused by not allowing enough slack in the "close" cable. It appears that the tension in the cables was causing friction in the throttle housing.

Also check that the throttle barrel is not up against the end of the handlebar.

Share this post


Link to post
Share on other sites

If none of those ideas work you can check the spot on the carb where the cables connect. I had problems with the wheel where they connect getting gummed with dirt. I also know a few guys that had the problem too. You could try cleaning around that, and it might free up your cables also. Good luck! :cry:

Share this post


Link to post
Share on other sites

Every 6 months I pull my carb off and clean it, inspect the cables to see if they are fraying and if they are good, lube the cables. When you put everything back together, if the cables are adjusted too tight, you will notice the throttle drags when you let go of the throttle. You should also clean out the the throttle housing as crud gets in there to. It takes 20 minutes to do and afterwards, the throttle return will be like new. My biggest fear is having the throttle stick or a cable break at the wrong time (on the face of a jump or the whoops).

Share this post


Link to post
Share on other sites

M96,

I have had the same problem with my '03 and I did everything. Well after theis weekend my clutch cable broke so I have the bike stripped down, litterly for major cleaning and checkout. I found that the throttle cables going into the carb (there is a black plastic cover over the cable pully assembly) were rusted to hell :cry:. I had been lubing the cables religously but apparently no lube made it to the "very" end. Long story short ordered new cables all around and will now lube from "both ends".

Hope this helps.

Don :cry:

Share this post


Link to post
Share on other sites

Clean and apply grease inside the throttle housing on your bars. It will work better than new. :cry:

Share this post


Link to post
Share on other sites

Throttle tube. Grip glue leaking through end of tube and building up over time? Gunk in bottom of tube. Rough bar under tube?

Sounds like you've done everything with the cables, but be sure to check the routing. No kinks or sharp bends. Be sure to check at all steering angles.

Share this post


Link to post
Share on other sites

my '02 does the same thing. someone posted the same question about 5 weeks back. my throttle cable binds someplace in the throttle on the teflon cable guides. i sprayed silicone lube and cured the problem for 4 weeks. it's binding again.

i think i will try moly grease the next time and clean out the crud as the dust collects.

Share this post


Link to post
Share on other sites

Try process of elimination, Disconnect the cables, Can you open the carb easily by hand ? Next check each cable, does each one slide freely ? Next check the throttle while installed on the bars, is it free ? If all are free then you probably have the cable free play too tight. :cry:

Share this post


Link to post
Share on other sites

Great,

Thanks for all the response you guys, I will look at all of it. :cry: Doug, you still sore from that '05 takin you for a ride the other day, or are you back up to speed?

Craig

Share this post


Link to post
Share on other sites

Craig, it wasn't the 05s fault...rider error. My ribs are killing me. I even went to the hospital for xrays. Nothing they can see, must be bruised. I'll be back out there soon.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×