Jump to content
Sign in to follow this  

03wr aus jetting question

Recommended Posts

check my sig for mods i just had first valve clearance check (all good) and my local dealer used some sensor and said my jetting was a bit lean and it had a slight flat spot off the bottom (as usual) so they lifted the needle 1 clip tested then another 1 when i got it back it seems to pop and miss while sitting at costant speed and it seems pretty flat in the middle part of the throttle rangeit is an aus model and had stock jets havent touched the carby it starts a little better but always started easy anyway and is more responsive when there is no load on it any help would be appreciated anything i missed just let me know 😢

Share this post


Link to post
Share on other sites

If it wasnt popping before then go back one clip position, then two if necesary. I run stock positions on mine beautiful. Same scenarion my dealer played with the clip and it ran like a dog so weve gone back to original. PS Im on mid coast NSW at Sea level. This may vary depending on your location 😢

Share this post


Link to post
Share on other sites

Try opening your fuel screw in 1/4 turn increments. If you get beyond 3 turns open from the fully seated position, you'll want to go up one size on your pilot jet. My WR missed at constant throttle settings when I first got it. Going from the stock 40 to a 42 pilot jet, and adjusting the fuel screw cured it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...