Jump to content
Sign in to follow this  

Oil change question?

Recommended Posts

I have a 04' WR450 and I just did my first oil change on it. The question I have is: I couldn't get the hose to break loose on the oil line to get to the screen. Any help would be great. I just went ahead and changed the oil the way it is now. I will change it again at 100 miles, at that time I will try to get to that screen. Thanks.....

Share this post


Link to post
Share on other sites

That bolt is torques on a lot. Use a breaker bar if you have to...

You don't need to get to the screen neither unless you just rebuilt the engine. The screen is there in case a chunk of metal came from the engine.

Share this post


Link to post
Share on other sites

Hey Top,

That hose is a royal pain in the ass. It took me about a hour to get it loose when I did my first oil change, Take the clamp completely off and use a small screw driver to pry around the edges of the hose. Its a braided hose so its pretty tough.

After I FINALLY got the hose out, the damn hexhead on the screen almost rounded off, they used real soft steel to make that apparently. After it was all said and done, I couldnt find ANYTHING at all on that screen, it was clean as a whistle (this was at 40 miles)

I decided I'm only gonna clean that screen once every 500 miles or so, its just too much of a pain to take appart.

I cut the [@#$%&*!] out of my finger on the edge of the stock skidplate too so be careful on that.

Share this post


Link to post
Share on other sites

Thanks for getting back to me, I'm glad I'm not the only one that thought it was a pain in the arse! 😢

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...