Jump to content
Sign in to follow this  

Pulse Generator?

Recommended Posts

My brothers XR400 has been acting up lately and I'm pretty sure its the pulse generator thats bad and he would rather not spend $205 on an OEM stator and pulse gen. since they are considered one piece. I ordered a WB Rev kit from the TTStore since it comes with a stator and pulse gen. and is only $90 more than the OEM pulse gen./stator and you get the entire electrical system. I got an email back that its (#74-100) is discontinued, but WB said that #74-114 is the same thing for only half as much. I think that means that they don't include the stator and pulse gen. anymore, but I will find out for sure tomorrow. Anyone know where I can get a pulse generator from?

Stuff that leads me to believe its the pulse generator:

*Misses like crazy at high RPM, but fine everywhere else

*Spare CDI box off my bike did the same thing (I got my XR400 used and it already had a rev kit on it but it still had the stock CDI box hanging on it, so I don't know for sure that its good)

*While troubleshooting it had no spark for about 20 kicks and then started working again and has worked ever since?

*Removed resistor and spring from plug cap and replaced with solid brass

*Cleaned the carb twice (158 main at 400ft)

*Cleaned spark arrestor

*I Adjusted the valves about 100 miles ago so they should be fine (bike only has about 1000 miles total

*Of course the first thing we tried was changing the plug

*Fuel filter clean and fuel flows fast out of fuel line

*Float level perfect

*Stator is 89ohms which is about right and I can see it puts out power with an analog voltmeter, plus the thing runs and has spark most of the time

Did I miss anything?

Maybe we just never revved it enough to hit the rev limiter before? I'm pretty sure its not THAT high of an RPM but what does that sound like? Is it a clean cut until you slow down, or is it really bad sputtering that never stops? We can't use my bike to troubleshoot because mine already has a rev kit on it and if the stator was changed, it might burn out his CDI, since the coil on my bike is tiny, it seems like it has to have more voltage to start with?

So basically the question is... Whats the cheapest place to get a pulse generator?

Sorry for being so long winded.

Thanks,

Joel

Share this post


Link to post
Share on other sites

I'm going to calculate the RPM from MPH and find out what RPM its at, if its just the rev limiter, then thats fine and We're freaking out for nothing :cry: since its very very rare to go that high of RPM anyway. Most of my concern is if something is wrong, We don't want it to completely die during a harescramble.

Joel

Share this post


Link to post
Share on other sites

Yep..... 38MPH in second on soft ground with 15/48 sprokets is about at the rev limit. I blame it on my brother who freaked out and caused the same reaction in me. We just changed the gearing to 15/48 from stock, so I guess that little bit extra made the difference, since he rode the thing for about 500miles before that and never hit the limit. I don't know how we managed to not get a spark at all when troubleshooting, but I guess we musta missed a wire or something.

I guess I'll leave this thread up so others can maybe use my troubleshooting list or just laugh at us :cry:

Joel

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×