Jump to content
Sign in to follow this  

05 MXC 450 clucth trouble

Recommended Posts

I race desert and have about 20 hours on my new bike....the clutch is giving me fits....it was down on fluid and I lost pressure....couldn't find any leaks but I replaced the line & used the proper KTM fluid....it then worked intermitantly...I took the plunger apart & cleaned it and bled it again....it worked good all day yesterday in the desert...but started fading toward the end of my ride...I have heard some screeching when taking off....I am hard on a clutch....but 20 hours? I put 200 hours on my last clutch (520 SX 6 speed) without any trouble....any ideas? My first MRANN race of the season is next Sunday and I am not happy & out of time to get parts.

Share this post


Link to post
Share on other sites

The screaching is just harmonics of the clutch basket, ignore that, have you modified your crankase vent hose? Is it kinked?

Share this post


Link to post
Share on other sites

My 520 didn't start screeching till the clutch plates were pretty worn out & I had chatter marks in the basket....after replacing them, the screech was gone....my new bike didn't start to screech until recently....I have been 10 times harder on this clutch than I was on my 520 and am afraid I may have smoked it already. The loss of pressure is a seperate issue though. Are you refering to the crank case breather being crimped and causing exessive heat? Again...the pressure loss would a seperate issue...I am thinking I have a bad slave cylinder.

Share this post


Link to post
Share on other sites

You very well could have a bad slave cylinder and just pumpint oil into the gearbox but before dwelling on that you need to make certain that the crankcase vent hose is not restricted in anyway! If it is crankcase presure builds up and pushes the slave cylinder piston back, thus you rev the engine up, then have to pump the clutch lever a couple time to push the piston back out before the clutch will work.

Share this post


Link to post
Share on other sites

I remember guys having the same thing happen to there bikes - I believe it was a O ring that was going out - it was letting the fluid leak out into the gear box - and it was very erratic - some days were fine then it would leak out again - the O ring was somewhere on the lower unit by the counter sprocket.

dp

Share this post


Link to post
Share on other sites
I remember guys having the same thing happen to there bikes - I believe it was a O ring that was going out - it was letting the fluid leak out into the gear box - and it was very erratic - some days were fine then it would leak out again - the O ring was somewhere on the lower unit by the counter sprocket.

That's where I'd look if the breather line is not restricted.

Share this post


Link to post
Share on other sites

I have an 05 450 and it started screahing at about 50 miles of not hard riding. I hear some just do it. I'ver heard that mobile one oil for autos will cause it also.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×