HELP with Devol Rad Guards

I just received the Devol Radiator Guards I bought for my 04 WR450. They weren't bad to install, but now I don't have a way to reattach my shrouds. One of the bolts in the shroud attached to the louver. With these guards, the louvers aren't used. Anyone experience this and have some hints??

There is a bracket that has 2 screws that hooks into the Devol guards, the scoops now hook that those. I installed Devols on my 04 WR450 and had no trouble. Are you missing some parts ot the kit? Was the package opened?

Thanks Tech. My kids opened the package before I got home. They said they didn't take anything out. When I asked 'em where they opened it I went and looked and lo and behold right there under the couch was exactly what you described that I needed. Appreciate the help, I love this forum. :):):p

Thanks Tech. My kids opened the package before I got home. They said they didn't take anything out. When I asked 'em where they opened it I went and looked and lo and behold right there under the couch was exactly what you described that I needed. Appreciate the help, I love this forum. :):):p

Cool, go easy on the kids, this dirt bike stuff gets them super excited too. Glad you found the missing parts! :D

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now