BRP not starting! :(

Hey BRP Riders,

I need some help with my new (to me) XR650R.

It's got a dialed-in Edelbrock and it's uncorked except for the stock exhaust tip. (Yoshimura slip-on is coming via mail now).

Anyway, I rode it last weekend and it ran great.

Today I try to start it and it just wouldn't start.

I know the drill because I rode an XR600 for 7 years and had starting dialed...

1) Turn gas on

2) Turn choke on (

3) Turn the idle up a bit

4) charge the cylinder

5) Get TDC

6) Kick it!

So I blipped the throttle since that's the Edelbrock choke.

Then I attempted to start the BRP and almost had it idling a few times, but everytime I'd give it just a little throttle to get the motor going, it would bog and die.

It did that a few times and I got pissed and ran it down the hill and tried to BUMP-START it.

No fire! Nothing. It's dead as a doornail and I'm exhausted and sweaty from kicking it and rolling it back up the damn hill a bunch of times.

Anyone know what could be wrong with this beast?

I'm guessing, but it sounds like the fuel inlet valve in the Edelbrock is stuck. If you can verify that the fuel is on but the accelerator pump is not squirting, then the fuel inlet valve is sticking. There's been a couple people here who have experienced this. Old Man Time here on TT had this happen a couple different times. Give a couple of good taps to the Edelbrock float bowl and see if that helps or take the fuel inlet valve apart to check for particulate, burs, etc.

See this thread for more info...

yep-thats what it sounds like!

happened to me a couple times. just a little bit of gunk where the inlet float valve sits--keeps it from backing out--and so the bowl wont fill with fuel.

tapping the bottom of the carb sometimes works...but cleaning it out by taking the bowl off the bottom of the carb is the best way. be careful not to drop the little pellet in the bottom of the accelerator shaft....all in all its an easy fix.

Hey Qadsan and Mike,

Those threads are LONG and they're scaring the crap outta me. :naughty:

Looks like first I need to...

1) Beat on the float bowl

2) And if that doesn't work - clean out the float bowl

3) And if that doesn't work - sand the brass piece that Old Man Time showed in his thread?

Anything else I'm missing?

My Edelbrock is only about 4 weeks old. I don't think it's full of varnish yet! :naughty:

It could simply be gunk in there. All it takes is a tiny bit of dirt, crud or gunk to mess things up and that's true of any carb. I'd take it apart, inspect it and spray it out. I just had to do this to my youngest son's XR200 because of gunk in the needle / seat and my oldest son's WR426 had dirt in the float bowl :naughty:

Alright Qadsan

Thanks for the info. You're a wealth of knowledge. :naughty:

I'll tear the Edelbrock apart tomorrow and see what's up.

It's probably an easy fix...

You really don't need to tear it down. Just pull the fuel hose off where it attaches to the carb and blast some carb cleaner in there.

If you do tear it down, be careful, there are some small parts that can fall out and you would not notice. Maybe Qadsan could elaborate. I don't really remember what it looks like in there.



OOPS! I did'nt see that Mike already mentioned the little pellet:

be careful not to drop the little pellet in the bottom of the accelerator shaft....all in all its an easy fix.

You might want to clean the petcock screen assembly while your at it..... :naughty:

Did you try the enrichning lever :naughty::naughty: time I left it on and the bike wouldnt friggin start :D:D

didint figure it out till I had the subframe off :D

Lets hope it's not a stuck float valve problem, again. All the added benefits or the edelbrock seem great and I'm waiting to get one too. However, one mishap like this with it would sour, for me, all the good it brings. I'll let my pocket stay $400 thicker for now. Come July she's getting one either way.

JackAttack is right. You don't need to tear down the whole carb. All you need to do is remove the fuel inlet valve if you want to inspect it. If you don't want to inspect it, then all you need to do is pull the fuel line off and spray some carb cleaner in there and see if that helps. I still have not had this problem happen in the last ~3.5 years I've been using my first Edelbrock carb, but I know where to look if I get this symptom thanks to Old Man Time :naughty:

Here's a couple of his pictures of the fuel inlet valve...

My carb doesn't have a fuel enriching lever.

I'll do what Qadsan suggests and just check the valve without taking the whole carb apart. That should save me some time and ensure I don't lose any parts! :naughty:

Don't expect to find any visible obstruction jamming it closed, when you inspect it.

Every drop of fuel that your bike uses runs across the tip of that needle valve. It is most likely that the fuel in the tank breaks down some of the components of the bike, such as the o-rings, fuel line, and other plastics. To form a bonding film that sticks to the needle causing stiction. Just hose the film off with carb cleaner.


Didn't see anyone mention the Spark Plug. I started mine in morning before heading to a race. Got the the race and it would not start. Missed start of race and loaded up bike, very pissed. Turned out to be spark plug. Found I had carb set up too rich and it fouled plug. Put in new plug and lit right up. I would do this first.

I wouldn't doubt it if it was a fouled plug.

I'll go git me a new one tomorrow and try that first.

Great idea... :naughty:

Yo BigTom17,

You were right! :naughty:

It was a fouled spark plug. Cost me $3 and 5 minutes to fix it.

I even got to ride today and practice my wheelies. :naughty:

Thanks :D

Yo BigTom17,

You were right! :naughty:

It was a fouled spark plug. Cost me $3 and 5 minutes to fix it.

I even got to ride today and practice my wheelies. :D

Thanks :D

Time will tell.

Same thing I did. After a while it would not start again. So I cleaned the needle valve and it worked fine after that.

Good Luck :naughty:


Dualsport650, did you check your spark plug. It sounds like it could be just that.

If it bog and dies, and now nothing. It sounds like what mine did not so long ago.

Started first kick with new plug :naughty:


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now