decompression question - burned???

Could I use the manual decompression set up from the kick start kit on my head since it is milled for it?

And wouldn't it allow me to use the hot cams exhaust cam and still let my starter easily spin the engine? Just hold it open until the engine starts, right?

10Guy, the Decomp will work on your E,,,But why? It should start with both HC cams....A bit slow at times,, and it may stall the starter at times.. But a quick re-push of the button has always worked for me. Though you are working 39cc more then I right now... :naughty:

Could I use the manual decompression set up from the kick start kit on my head since it is milled for it?

And wouldn't it allow me to use the hot cams exhaust cam and still let my starter easily spin the engine? Just hold it open until the engine starts, right?

yes,but you need to set it so it just barley opens the valve.

I'm going to try the hot cams exhaust again now that it is broken in and see how it does, before break in I couldn't get it to turn over even when jumped from the jeep battery. I just figure that if it would work and I could pick up one (may even get a kick starter for backup) it would reduce the load on the starter therefore allowing it to last longer. It should also be easier on the battery as far as it's drain each time to start.

I'm still not sure that I want to run the hot cams exhaust around here anyway, this thing has way more power than I need and it is so smooth that I was getting way more traction than before in the same areas. I'm going to have to go try it out in the wet and see.

Hey 10Guy,

I got an 440/EX&IN Hotcams/YOSH FullSystem/ set up on my bike and I am able to start it with my battery. It even starts here at 0 degrees Celsius. But I have the "E" model compression on mine not the 13:1 you have.

I was too thinking about the kick starter as a back up ....but spend all the dough on the Yosh....so this will have to wait.

when installing the kick start kit on an S model there is no need for the decomp lever right since it has auto decomp on the cam?

when installing the kick start kit on an S model there is no need for the decomp lever right since it has auto decomp on the cam?

right,but you couldnt install it even if you wanted to.the hole in the head isnt there.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now