2002 520 MXC tranny problems

I have finally received all my parts and started to toy with my old beast (2002 520 MXC). I put the new crank in and all new gaskets, bearings, and seals in the lower end, I put it back together using a factory KTM service manual. I just can't seem to get the tranny right. The shift forks are mounted correctly I think, and it will shift through all 6 gears. But when I kept going on the lower end, I installed the freewheel, kickstart and e start drive gears, clutch, ect. ect, the damn thing will not shift out of neutral now. I can get it to 1st gear, and then neutral, but the damn shift drum wont push it past the neutral position for 2nd and so on.

Any suggestions before i tear the bottom end apart???

Inoc

ty in advance I am about to start throwing my tools around the garage :naughty:

Travis I know you know some secrets.....spill the beans if you would. Any ideas or suggestions? Should I be able to find all 6 gears before assembly, or do i need to do a dry fit and check the shifting. I have it all apart again and ready to assemble if I hadn't dropped on of the shift fork roller guides on my garage floor and now I can't find it. I am now waiting fora few to come in. Talk about the dollar waiting on a dime!

Inoc

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now