Jump to content
Sign in to follow this  

2005 CRF 450 clutch

Recommended Posts

Is anyone out there having clutch problems on there 05 450, I have gone though 3 clutches in 1 month. 2 times pulled out the old clutch and all the friction material is rubbed off of several friction plates? I have never seen this before. Tried honda 10-40 and amsoil 20-50. Any suggestions?

Share this post


Link to post
Share on other sites
Is anyone out there having clutch problems on there 05 450, I have gone though 3 clutches in 1 month.

No problems on mine. Sounds like operator error.

Share this post


Link to post
Share on other sites
Is anyone out there having clutch problems on there 05 450, I have gone though 3 clutches in 1 month. 2 times pulled out the old clutch and all the friction material is rubbed off of several friction plates? I have never seen this before. Tried honda 10-40 and amsoil 20-50. Any suggestions?

How hard are you on the clutch. Do you like to ride on the rev limiter using the clutch. Are your steel plates blue.black in color, if so your clutch is slipping real bad and thus chewing up your clutch. Were they OEM or after-market. I use Mobil 1 (Red-Cap 15/50) Full synthetic.

HTH

Ian

Share this post


Link to post
Share on other sites

Close to 30 hours on mine and no probems yet. Are you doing moto or close type woods riding. If you are staying in first gear too much try adding a few teeth out back to help. If you are doing moto and frying it that much you must be riding the shiz out of it. :naughty: Never having this problem before though makes me think it is not rider error. Maybe you should replace the steels also just to see if that helps. By the way I use Mobil 1 15w50 in mine. I hope you figure it out, good luck. :naughty:

Share this post


Link to post
Share on other sites

I dont know if it's related but after only 15 min ride, the transmission on my brand new CRF450X05 just blow out !!! I've been waiting for this bike for a month than after only 8km, bang !!!!

Share this post


Link to post
Share on other sites

I would look at some other issue other than weak clutch. I have been doing enduros on mine since Nov 04 and only had to replace the clutch basket, no plates. These have been tight, nasty enduros also with lots of clutch work on the stock gearing.

Share this post


Link to post
Share on other sites

wow, that is strange.

we have had and run lots of the hondas , 4 and 2 stroke and just don't ever see a bad clutch hardly at all.

lots of 05's with no problems , and these get pounded hard !!

now i have had some differe'nt oil's that the honda clutch would slip on but i just took the clutch out and washed it all off real good and reinstalled it with normal hp-trans oil and the thing worked just like it was supposed to .

i have not used the amzoil , but i have see guys use the wrong honda oil and or some diesel oils and the thing will slip within 10 min of use and if not corrected it will die :naughty::naughty:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×