Jump to content
Sign in to follow this  

Jetting Quandry 05 YZ250F

Recommended Posts

I have a 2005 YZ250F that runs good most of the until it rains or gets muggy.

I have a Quick shot mod on it and a Yoshi slip-on. Jetting is stock and seems to work good in the summer here. It has been raining rather often here and I notice the bike runs like crap, it seems to run rough and when I open it up, it pops and seems to hit the limiter way soon. On none raining days, it runs great pulls good and so on. What could be my problem? Thanks in advance. :applause:

Share this post


Link to post
Share on other sites

Running bad in humid weather sounds like its overly rich to me. I'm not sure if you can read an iridium plug like you could a standard one (never used one myself), but if you can check and see if its black.

Share this post


Link to post
Share on other sites

Thanks, you are right it sound like it is rich. My confusion is I have a pipe and running stock jettting, how can it still be rich? I also started noticing more after the quick shot install.

Share this post


Link to post
Share on other sites

I'm usually at about 100ft above sea level, but the other place I ride at might be slightly higher. I will try go down on the main jet and maybe one clip up on the needle jet. :applause:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...