Top Triple Clamp

Well i have oversized bars, and i have the adapters that go on the stock bars.

Due to the rubber mounts on the stock clamps, every time i lay my bike over the bars tweak. I was was dondering what top triple clamp everyone used that dosent have those rubber posts. Thanks

Oh yea can we keep it cheap.

hmm well i use the black universal top clamp and run the renthal twinwalls, outa all the bar/clamp combos this seems the best to me...check motosport.com they have some good deals...

http://i7.photobucket.com/albums/y286/kx250frider651/Picture016.jpg

this is what clamp im running i like it ALOT..it gives u 2 choices to use rubber or just the hard style..i use the rubber (very hard compound rubber) to avoide vibration and it never tweaks when i crash, its probably cuz its 10 times better than the stock rubber mounts it comes with, it also comes with the big oversized 1 piece bar clamp which it alot nicer than the small 2 piece.....

http://www.motosport.com/product.jsp?path=-1|31989|37204|102830&id=48182

the rubber is nice, on my old bike (RM 125) i have procircut trips which are nice and i would reccomend, but they are billit and when i fell hard bent the mounts. On the RMZ i have oversized bar adapters and i just fell pretty bad bending a set of taperwalls and it just tweeked the mounts in the rubber, i loosened it up and everything is fine. I hear that RG3 trips are one of the best but i have never used them.

Thanks Kx250FRiDeR651! I looked into it and i think im gonna go ahead and order one!!

i use the black universal top clamp

When you installed the Universal top clamp, did you have any clearance problems with the CDI box or cables?

I installed an Applied upper clamp with the rubber mounts. The mounting bolts and nuts on the bottom of the clamp would rub the CDI box when I turned the bar one way or the other. It also interferred (binding) with the cables running along the LEFT hand side (sorry, forgot which ones) of the bike. The Applied nuts were much thicker than stock. I called Applied who said they would look into it and never got back to me.

Just looking for some solutions to resolve this. Thanks

Mark

When you installed the Universal top clamp, did you have any clearance problems with the CDI box or cables?

I installed an Applied upper clamp with the rubber mounts. The mounting bolts and nuts on the bottom of the clamp would rub the CDI box when I turned the bar one way or the other. It also interferred (binding) with the cables running along the LEFT hand side (sorry, forgot which ones) of the bike. The Applied nuts were much thicker than stock. I called Applied who said they would look into it and never got back to me.

Just looking for some solutions to resolve this. Thanks

Mark

i have absolutley no problems with cables being in the way..the clamp went on very easy, i used a rubber mallet so i wouldnt scratch it up...maybe try re-routing the cables..if u want i can take my number plate off and give u soem good pics of how mine are routed...but other than that i have no issues

Applied.

Good enuff for the Factories, good enuff for me!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now