Jump to content
Sign in to follow this  

520 EXC Noise

Recommended Posts

I just bought a 2000 520 EXC. When I start it cold it makes a loud klacking noise. It sounds like valves. It stops soon after(about 10secs.) Is this normal?

I rode it this past weekend and love it.

Share this post


Link to post
Share on other sites

It may need to have it's valves adjusted. Let us know if that cures it.

------------------

John Brunsgaard

jejb@att.net

01 400 EXC, 99 250 EXC (gone), 99 200 EXC, 98 125 EXC, 98 380 MXC (long gone)

Share this post


Link to post
Share on other sites

i would take it back straight to the dealer and tell them cause if it aint the valves then it could be something that could cause big damage ie - clogged oil line or filter. If u continue to ride it they might void any warranty claim cause u didnt have it looked at straight away.

Share this post


Link to post
Share on other sites

I assumed since it's a 2000 bike, it was used and, therefore, out of warranty long ago. If it is indeed a new bike, I agree with Trickster.

------------------

John Brunsgaard

jejb@att.net

01 400 EXC, 99 250 EXC (gone), 99 200 EXC, 98 125 EXC, 98 380 MXC (long gone)

Share this post


Link to post
Share on other sites

Thanks for your replies. My previous bike was an XR400 and I think that I was worried for no reason. It does sound very diferent from my Honda. I now have more time on it and have had others listen to it. It seems fine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×