Jump to content
Sign in to follow this  

Jetting ? Or something else ?

Recommended Posts

I just switched my stock filter with a new ready racing preoiled filter. It is seated correctly and has been sealed with grease. Ever since I switched out to this new filter I have a loud popping on deceleration ? I'm currently at 2100 elevation running stock jetting and a 172 main jet? Any Ideas ? :banghead:

Share this post


Link to post
Share on other sites

Lean.. The filter could have had too much oil on it and clogged your pilot jet and others. If you have made no other changes, I would check that. My bike ran great and all of the sudden I got the pops on decel. checked the pilot,,,clogged..If the pilot is clogged it will create a lean condition. When mine got clogged, the bike had difficulty idling also..

Just my .02..

Share this post


Link to post
Share on other sites

Are you running U4 gas? It will cause the eventual clogging of the pilot jet if you don't drain the tank AND float after each ride. If using pump gas, I guess the pilot could get clogged another way. If the pilot is clogged you will get the deceleration pop constantly. Change it out, they're about $5. Before replacing, try turning the pilot screw out within another turn to 2 1/2 turns out max.

Share this post


Link to post
Share on other sites

at 2100 feet you dont need the fuel screw all the way out to 2 1/2 turns. 1 and 3/4 should be more than enough.

If the filter was over oil and it clogged a jet, it would have clogged an air jet in the carb mouth and the thing would have went way rich, not lean.

A pilot jet blockage is possible and really easy. The hole in that thing can be completely obstructed by half a grain of sand.

The mention of U4 is a good one too. That stuff goes nasty in a big fat hurry.

Simply dail about an 1/8 to 1/4 turn out on the fuel screw and the decel popping will go away. If you did nothing you wouldnt be damaging anything beyond the muffler packing.

If you care to notice, at almost every supercross race Ive seen they all pop a little on decel. It seem like they tend to run the best when they pop a tad.

One other thing, Id be surprised if the air filter was the sudden culprit here. If this was sudden, Id look at the header for cracks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...